this is the place to discuss the workings and failings of RemoterSA. comments and bug reports welcome…

I don’t seem to be able to run it as a plugin, I bet its the utils again! I put in the new ones in the archive…
Also whats the timeliner section for, Does it just send a report via udp?
Also it doesnt seem to save my new file paths after saving and restarting…

@cat…it appears here as plugin in vvvv if i just drag n drop the dll into the patch. and it saved the filepath to PStools too.

Can’t drag and drop it either, in fact it doesnt show up in the list even…

drag n drop out of the folder i downloaded…not out of the vvvv plugin folder.


i haven’t yet tested it as a plugin at all. don’t suspect the in and outputs to be (and or do something) meaningful yet.

all references to timeliner are copypaste-remainders that will be gone with beta2.

I’ve followed the steps to get PStools working and verified as specified… however it doesn’t work in RemoterSA I get the error

ERR C:\Program Files\PsTools\psexec.exe: The directory name is invalid

anyone know what I may be over looking?

Looks like it might not be parsing arguments??? I’ve got C:vvvv_40beta21\vvvv.exe /client

helo wrongelectron,

i cannot follow… you specified the correct path to psexec.exe and still get that error? works for me. anybody?

i am not sure what it should have to do with this:

Looks like it might not be parsing arguments??? I’ve got
C:vvvv_40beta21\vvvv.exe /client
this is the command line to start vvvv. it has nothing to do with RemoterSA, right?

I get the attached JIT error when I try and enter any text into the either box after pressing + to add processes to watch. I’ve set the pstools path and admin name and pass, any ideas?
I’ve edited the savegames.xml to put vvvv it the path where notepad was (with full path) I’m only trying to get this to work on this pc at the moment, ie get the watch dog to restart the process if it fails, but I don’t see to be able to get anything to happen, ie start the process or restart it etc.

Ahh, I’ve added ip, selected it, clicked start, and the message box returned ERR but I did get some pstool licence boxes pop up, so thats a start!

And killing the process works, just not starting it, restart kills it then returns an error.

error.txt (4.0 kB)

ja, sorry, i am aware of that bug. take the attached intermediate version as a quick fix. it has another bug though, as digitalslaves found out: it won’t let you enter the path for UltraVNC (so you’ll have to edit that one in the savegame.xml) (68.9 kB)

Still don’t seem to be able to start the process, killing is fine, but restarting doesn’t happen…?

mm…you’re only trying this locally? have you tried as the local IP?

for me it just takes ages locally to startup a process. but eventually it comes up. you can observe in the taskmanager first a process called psexec.exe popping up, followed by another similar called one…does that happen?

psexec pops up, remoter takes up 35-50 cpu, ie most of one core, how longs an age, just left it about 10mins, will keep it there, but that seems quite a long time! I’ll report back if it pops up soon!
And yes I’m using I also tried it actual ip too. What am I doing wrong!

I’m having a really weird problem here. I’m getting this same error > “The directory name is invalid” when trying to run c:\Program Files\vvvv40beta23\vvvv.exe using RemoterSA_beta5.

I’ve used remoter a few times now with no problems and full functionality. The only difference now is I’m using it on a XP x64 machine.

Doesn’t matter if I try moving vvvv to another folder on the computer or change the folder name. Now the really funny problem is that I copy the same RemoterSA folder from this x64 machine and put on an x86 machine it works fine firing up vvvv on the x64 machine! Same version of remoterSA and savegame.xml.

I’ve come up with a hack to get the x64 executing vvvv on the x86 machine by creating a batch file in the c:\windows folder that executes vvvv.exe with two arguments so I can set /client and the IP address.

Why would x64 be the issue? Has anyone ever used remoter in x64 talking to x86 or a x64 group. I know it not the most sensible way around to run a boygroup but saves buying a XP pro licence.


wouldn’t you know it? It has just started working fine from my x64 machine. Literally haven’t changed a thing with RemoterSA or background stuff in XP. No more ‘The directory name is invalid’.

first. kewl piece of software. uvnc and pstools work like a charm. with the actual beta5 i cant copy via mirror. do i forgot something? it throws me out the mirror-help-description in the loginfo (with test only and without)…

thanks for all and regards from berlin - chmee

@chmee: without knowing it i assume that for mirroring :
*the destination folder has to exist on the destination machines
*the destination folder has to be shared allowing write access

… and ‘simple file sharing’ must be off…