Forum

Random error using menu

I got this error when I tried to open the menu - not sure whether it was the gray square or the file name I clicked. Maybe the error message helps.

************** Exception Text **************
System.InvalidCastException: Unable to cast object of type ‘VL.Model.Fragment’ to type ‘VL.Model.Node’.
at VL.Model.Compound.GetNewElement[TElement](TElement oldElement) in C:\BuildAgent\work\9506352823f45313\vvvv50\VL.Lang\src\ImmutableModel\Basics.cs:line 639
at VL.Model.Solution.GetNewElement[TElement](TElement oldElement) in C:\BuildAgent\work\9506352823f45313\vvvv50\VL.Lang\src\ImmutableModel\Basics.cs:line 708
at System.Linq.Enumerable.WhereSelectEnumerableIterator2.MoveNext() at System.Linq.Enumerable.WhereEnumerableIterator1.MoveNext()
at System.Linq.Enumerable.Any[TSource](IEnumerable`1 source)
at VL.HDE.PatchEditor.NavigationMenuProvider.AddNodesByCategory(MenuEntry menuEntry) in C:\BuildAgent\work\9506352823f45313\vvvv50\VL.UI\src\VL Forms\PatchEditor\NavigationMenuProvider.cs:line 201
at VL.Lang.Menu.MenuEntry.get_Entries() in C:\BuildAgent\work\9506352823f45313\vvvv50\VL.Lang\src_legacy\Menu\MenuEntry.cs:line 149
at VL.HDE.PatchEditor.NavigationMenuControl.CreateMenuItem(IMenuEntry menuEntry) in C:\BuildAgent\work\9506352823f45313\vvvv50\VL.UI\src\VL Forms\PatchEditor\NavigationMenuControl.cs:line 592
at VL.HDE.PatchEditor.NavigationMenuControl.ButtonDropDownOpening(Object sender, EventArgs e) in C:\BuildAgent\work\9506352823f45313\vvvv50\VL.UI\src\VL Forms\PatchEditor\NavigationMenuControl.cs:line 823
at System.Windows.Forms.ToolStripDropDownItem.OnDropDownShow(EventArgs e)
at System.Windows.Forms.ToolStripDropDownItem.ShowDropDownInternal()
at System.Windows.Forms.ToolStripDropDownButton.OnMouseDown(MouseEventArgs e)
at System.Windows.Forms.ToolStripItem.HandleMouseDown(MouseEventArgs e)
at System.Windows.Forms.ToolStrip.OnMouseDown(MouseEventArgs mea)
at System.Windows.Forms.Control.WmMouseDown(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ToolStrip.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

for that one we’d need more infos. any way to reproduce this?

Sorry, can’t find a way to reproduce. Was hoping the error message helped somehow.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.