Forum

Projection mapping Calibration error on kinect generated mesh

hello everyone,

ive been mapping objects with the Point editor and a grid mesh for the past years,but has been Only one object and the rest of the scene is not mapped and i havnt really had to change cause it gave enough sofistication for semicomplex shapes.

Now im trying to map a tree and its branches, and point editor or a homography transformed quad will not cut it.

Now moved to a more easy target

I´ve been using elliots patch for kinect+Reconstructme+vvvv but in the calibration process i cannot get it to work.

once i imported the object and tried to make it look as close as the projection. I add more than 4 points and the object dissapears, tried other surfaces and still the same thing happens. and if not is completly irrevernt to the points ( even after reseting it pressing space )

( ive put more than 9 points for calibration and still my model wont appear or its warped out)

Halp plz!

does anybody know whats going on or what step am i doing wrong?
or if so another technique i can use for calibrating my model with the real object?

cheers

Hello I,m not too sure what happens , just to confirm . once you have your camera a bit similar in look to the reality you set a point in the virtual and then you set this same point in the real so you move mouse and click in one renderer and later you do in the other until you see the points are in its place. Maybe you could try with a simple box as you can decide the size and position easily without any external model then put the same one in reality and try the technique with some points so you make sure you are doing it right. cheers

There are issues with Elliots cv plugins and various versions of v4, I dont know whether he has any fixes yet, I report this to him a couple of months ago.
http://www.kimchiandchips.com/files/vvvv-sdk.zip
Try it with this version of v4, but you might have to use older versions of the image pack too…