Problems loading file textures whilst boygrouping

I have an identical file folder containing images on the desktops of both my server and client computers. When boygrouping the images don’t want to load on the client computer. I can load each one manually but i have so many i can’t do it every time i turn on my computers. As usual I feel like I am missing something basic but essential. Any ideas?

this is hard to guess. probably attaching your patch here would help.

Are the folder in the same location on both machines? If they’re on the desktop are the user names the same for example? Is the boygroup send a absolute url or a relative?

If the user name is different could that cause the problem? I think they are different-- I will fix this as soon as I get home. I guess I don’t know the difference between absolute or relative URL.

if the file name is transmitted as an absolute path and the user names are different then the paths will be different, pop a boygrouped iobox just above your file texture node to inspect the path on both machines.

have a look at the nodes RelativePath (File) and AbsolutePath (File). i’ll attach a patch where i sketched the usage of those two in your scenario.

absolute_vs_relative_paths.v4p (10.2 kB)

Cool, never seen those 2 nodes :) Thnx Elias

Both RelativePath and AbsolutePath are missing on my version (25.1). Unfortunate because it may help me with my problem. It seems that even though my image files in identical folders on the desktop with the same username the paths are still different-- possibly because one machine is running vista and the other XP (???)
The weird thing is that if i start a new patch in boygrouping mode I can pull these textures up on my server and they pop right up on the client-- until I save the patch, close it, and then re-open it-- i no longer have the ability to do so. Then I have to manually type in the path as it appears on the client.
Does this make sense? Is this solvable with the ReelativePath and AbsolutePath nodes and if so where can I get them?

I am currently making lists of these file paths as a workaround solution, but they will be invisible on my server computer. i wish there was an easier way to do it but whatever works, right?

thank you for your helpful responses-- i am continually amazed at the community here

try to concatenate your paths with SystemFolder (File ) with Folder set to UserDesktop and Add (String) this should solve different the case of different user settings on the machines.
or copy your images on a folder on hdd c, then the folders are the same for each machine

You can’t have those nodes in beta25.1 as they have been introduced with beta26.
For several reasons it is really recommended to switch to 27.1.

i consider myself quite conservative in terms of switching to new vvvversions; but i did switch to 27.1 which IMHO is running quite fine.

I have developed my own way of working consistently with folders across computers.

I always setup my computer this way, that way it is a lot easier to move between machines.

I move my documents folder to:

and change where windows see the default documents folder to this location

I place vvvv in:

c:_vvvv\vvvv_45beta27.1\ (In the case of beta27.1 it contains multiple versions of vvvv simultaneous)

I Place content for a project in either:




if you set up all your machines with this structure, you should be able to what you want to easily. you could use RemoterSA to syncronize the folders on all the machines: remotersa


yes!!! thanks everybody…