Forum

Problem with collada texture in 32bit


#1

Hi,
I wanted to ask if there is a known issue with collada textures in 32 bit. As the gray scale model loads fine without the filetexture but when I add the filetexture I can only barely make out a black model.
I have tried opening the exact same patch in 64 bit and the models loaded fine with the textures.
The main problem is my project involves the use of Fiducial trackers which are only available in the 32 bit version. I have attached the images in the following order: 32bit with texture, 32bit without texture(gray-scale) and the 64bit with texture which loads fine.
32Bit%20with%20texture 32Bit%20without%20texture 64Bit

Thanks!


#2

Looks like the texture does not load at all. Did you check the filepath is ok when running 32bit (maybe relative filepath is used?) Does filetexure report ok on its valid pin? What happens when you feed any other texture, like from the assets node?


#3

DX9 or DX11 file texture?

Maybe try all.

If the problem stays, please post the texture.


#4

I think there is a limit on texture size, try resize to 8192x8192 or 4096x4096


#5

Thanks for the replies!

I tried reducing the size of the texture like antokhio said to 4096x4096 from 8192x8192 and seemed to work but the texture I think is now mapped wrongly:

Probably due to the changes in the dimensions. Anyone knows how to properly decompress a model? Any suggestions are welcome.

Thanks!


#6

try flipping the texture scale around from 1/1 to -1/1 and so on… . resizing the texture (als long as you keep it power2) should not mess up your texture mapping, just change the resolution.

what do you mean by “decompress” a model?


#7

Sorry, I didn’t mean decompress actually I meant compress to reduce the file size.
Also I am quite new to all this 3D modelling so can you explain what you mean by flipping the texture scales again?

Thanks


#8

scale the texture transform x/y of your shader (for example constant dx.11) it from 1/1 to -1/1 - then you flip it horizontally. try it out on a quad.

I don’t know if different 3d formats have file size advantages. a model gets loaded from your drive onto the gpu once, and everything else happens there. a smaller file would just load faster in the beginning.

If you are talking about reducing the number of vertices (edges) in your 3d file, thats not that easy. I suggest you have a look at how 3d modeling works (vertices, uv mapping etc. to get a better understanding.

remeshing is probably fastest with zbrush zremesher.


#9

note that for fiducial tracking you can alternatively use the separate reacTIVision software that will send TUIO data that you can receive with vvvv x64


#10

Hi joreg,

Can you provide me a small example patch on how to use TUIO to just read and return fiducial ID?
As I can’t seem to find any tutorials on this.

Thanks


#11

@acfrost see

girlpower\IO\TUIO

#12

I have tried out the using tuio_patch but it is only returning null values. Am I missing something? The fiducial tracker is being recognized by the reacTIVision application. I am also running the vvvv Tuio_toolkit.
P.S. Sorry if it is something very simple as I am very new to this.


#13

See the exclamation mark above the udp node, it refers to the status pin of the udp node, check the output. Also dont open multiple patches with udp server on the same port. the port number only can be bound once and can not be accessed by later created udp nodes.


#14

The status says OK, but the values are still null in vvvv.


#15

are you really sending to port 3333? Tried disable firewall? See at least any raw data on the udp node output?
And dont you actually need TUIO object, not cursor?


#16

I just got it working with the TUIO object.
Thank you all very much! :)