Forum

Problem with BIG Jpeg


#1

Hi,

for an installation I’m patching for a friend, I need to read a Jpeg with the size of 29999 x 22004 pixel. I tried to load this Image via file texture on a quad on beta 0.9. With a smaller image all is working perfekt, with the big one nothing happens. I even don’t recognize any accses to the Hdd.

The image is a Panorama with many details, in which one should be able to zoom in and move arround. Its done with photoshop, where I don’ have problems whith fluid movement.

Is that an hardware or an software problem ?


#2

max texture size is 4096*4096, i guess. cut the texure in slices of max this size and display it on a spread of quads …


#3

Ok, splitting the image into smaller slices an using several quads worked. But when I use all slices v4 is getting very slow. Windows blows up the virtual Memmory to 1,3 GB. (I’m using a 1,7 MHZ Pentum M Laptop with 1 GB Ram and FireGL Grafik with 128 Ram).

What is the best way to accelerate v4, more Ram or another Grafik Card ?


#4

it should be possible to calculate how many of your splitted images you can fit into the 128mb of graficcard ram.

widthheightbitdepth (of texture format)
try playing around with different textureformats in the inspektor with FileTexture selected! if your texture has no alpha you can take a 24bit format at least. also try the DX1-DX5 formats. they are compressed formats which should further improve your situation.


#5

and in a very general sense:
it’s always recommended, better to optimize the software wherever possible before thinking about “bigger” hardware.

in this case: load the textures dynamically on demand. that means only a few “left”/“right” to the actual position ( there raises the question of threaded file-loading…(just for the devs) ), instead of loading all of them at start up.


#6

Ok thanks for the infos.

We’ll be able to use a faster machine next week. If the problem couldn’t be solved with this machine nor with different texture formats, I will try to dynamic load the textures depending to zoom an section…

Gruss Jochen