Forum

Problem fetching vvvv-sdk binaries

devvvv

#1

Hi,

tried to setup up vvvv-sdk on my win7 64bit machine. I had no problems forking and checking out the sdk. But when I tried to fetch the binaries via:

scripts/fetch-binaries x86

I got the folowing feedback:

/d/VVVV-Projects/vvvv-sdk (develop)

$ scripts/fetch-binaries  x86
Unable to find version '32.2.0-develop-330' of package 'VVVV.Binaries.x86'.
Copy-Item : Der Pfad "D:\VVVV-Projects\vvvv-sdk\packages\VVVV.Binaries.x86.32.2.0-develop-330\content" kann nicht gefunden werden, da er nicht vorhanden ist.
In D:\VVVV-Projects\vvvv-sdk\scripts\fetch-binaries.ps1:42 Zeichen:9
+         Copy-Item (Join-Path $contentFolder "\*") -Destination $vvvvRootPath
-Re ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (D:\VVVV-Project...lop-330\content:String) [Copy-Item](Copy-Item), ItemNotFoundException
    + FullyQualifiedErrorId : PathNotFound,Microsoft.PowerShell.Commands.CopyItemCommand

Any ideas what could the problem here?


#2

hmm,

manually added the missed folders:

vvvv-sdk\packages\VVVV.Binaries.x86.32.2.0-develop-330\content

no the
script tells me:

Unable to find version '32.2.0-develop-330' of package 'VVVV.Binaries.x86'.


#3

does it work if you open the file scripts/fetch-binaries.ps1 with notepad and replace line 40 with

& $nugetExe install $packageName -Version $packageVersion -OutputDirectory "$packagesPath" -Source "http://vvvv.org:8111/guestAuth/app/nuget/v1/FeedService.svc/"

#4

Jep looks good!

that’s the output:

$ scripts/fetch-binaries  x86
Installing 'VVVV.Binaries.x86 32.2.0-develop-330'.
Successfully installed 'VVVV.Binaries.x86 32.2.0-develop-330'.
AUSFÜHRLICH: Ausführen des Vorgangs "Datei kopieren" für das Ziel "Element:
D:\VVVV-Projects\vvvv-sdk\packages\VVVV.Binaries.x86.32.2.0-develop-330\content\setup.exe Ziel: D:\VVVV-Projects\vvvv-sdk\vvvv45\setup.exe".
AUSFÜHRLICH: Ausführen des Vorgangs "Datei kopieren" für das Ziel "Element:
D:\VVVV-Projects\vvvv-sdk\packages\VVVV.Binaries.x86.32.2.0-develop-330\content\vvvv.exe Ziel: D:\VVVV-Projects\vvvv-sdk\vvvv45\vvvv.exe".

Thanks!


#5

Ok - will be fixed.