Forum

Problem bubble.fx

hi,
the shader bubble.fx doesn’t work me, the rendering is black.
the shader version test has given me shader 3.0.
I have tried above more than a computer. how can I resolve the problem?
thanks

Hi,
strange…have u been waiting for a few secs ?..because bubbles doesn’t shows up at the begining…needs time to rise…and also check if it compils, if techniques are valided and if textures loads well…

Hi,

Do you have an ATI card?
There are several FX that don’t work for me on either of my desktop Radeon X1600XT or my laptop Radeon X1700.

The problem is always the same black renderer.

Also not working for me are Quaternion Julia Set (my biggest regret), Lyanopulov (think thats how it’s spelt) and Mandlebrot and Julia set fractals, plus maybe some more.

At least it’s getting me to look into the code a bit more.

I havn’t worked out the problem, though I remember a problem with ATI and vertex textures or something being discussed here a while ago.

Now I remember, I’m going to try different versions of vvvv with 'em.

Made them under Nvidia Geforce…tonfilm’s too…i also have an ati but doesn’t support VS 3.0 so i can’t test…let me now about your next steps…TX

I can confirm that it doesnt work on an ati x1600, ps3 but not wholly it seems! its fine on my nvdia!

Yeah, Radeon’s don’t support vertext texturing.
They don’t properly support Vertex Shader 3.0, which I believe all the non working fx use.

Heres a better page that explains it all

So both my ATI’s are non VS3.0 compliant.
This is why the fx compile without errors, but don’t work.
They are lying to the software.
Shame. I am buying a new nvidia card for my shuttle.

in the notebook I have an ATI radeon x1600 and it doesn’t work in desktop where I have a nvidia geforce 7300 gt it perfectly works.