Forum

Pointeditor legacy question

not sure if a bug or what,if i opened old version patch with beta28.1,the pointeditor will be convert it to the pointereditor(3d legacy),but its not working unless i changed it to pointeditor(3d persistent)

the Pointeditor (3D) being replaced by a PointEditor (3D Legacy) when opening an old patch is correct. in the same patch the mouse-node connected to the grideditor should have been replaced by a legacy mouse-node and the two should work together nicely (even though you said they don’t).

what you can then do is replace the legacy pointeditor and mouse nodes by their non-legacy versions and redo the connections manually.

can you provide a patch that shows the problem?