Forum

pluging->SkeletonNodes->selectJoint error

typing the selectJoint node turning red,the error message saying that:

Object reference not set to an instance of an object.


Exception log with detailed tech info. Generated on 2011/12/20 11:41:18.
You may send it to the application vendor, helping him to understand what had happened.
Application title:
Application file: F:\Dev\vvvv_45alpha26.1\vvvv.exe

Exception class: EClrException
Exception message: Object reference not set to an instance of an object.
Exception address: 00000000

System.NullReferenceException: Object reference not set to an instance of an object.
at VVVV.Nodes.SelectJoint.Evaluate(Int32 SpreadMax)

Main thread ID = 4124
Exception thread ID = 4124

Exception stack
Stack list, generated 2011/12/20 11:41:18
0059AB51{vvvv.exe } ClrUtils.ClrCheck (Line 1048, “ClrUtils.pas” + 2)
00660CD3{vvvv.exe } PluginNodes.TMPluginWrapperNode.EvaluateV1Plugin (Line 298, “PluginNodes.pas” + 1)
00660AC5{vvvv.exe } PluginNodes.TMPluginWrapperNode.Evaluate (Line 257, “PluginNodes.pas” + 24)
0069CB2D{vvvv.exe } Graph.TMPin.GetUserSliceCount (Line 2970, “Graph.pas” + 1)
006624CA{vvvv.exe } PluginNodes.TMPluginWrapperNode.CalculateNodeAndOutputSliceCounts (Line 936, “PluginNodes.pas” + 8)
00699634{vvvv.exe } Graph.TMBasicNode.Prepare (Line 1128, “Graph.pas” + 20)
0069B682{vvvv.exe } Graph.TMPin._Prepare (Line 2347, “Graph.pas” + 4)
0069B805{vvvv.exe } Graph.TMPin._ValidateAllSlices (Line 2382, “Graph.pas” + 9)
00699701{vvvv.exe } Graph.TMBasicNode.ValidateAllOutputs (Line 1179, “Graph.pas” + 2)
00660936{vvvv.exe } PluginNodes.TMPluginWrapperNode.PrepareGraphCB (Line 221, “PluginNodes.pas” + 1)
00664A3B{vvvv.exe } PluginNodes.TMPluginWrapperNode.PrepareGraph (Line 1824, “PluginNodes.pas” + 2)
00699ABB{vvvv.exe } Graph.TMBasicNode.PrepareGraphCB (Line 1306, “Graph.pas” + 2)
006AEBE5{vvvv.exe } Events.TMEvent.Call (Line 403, “Events.pas” + 11)
006ABFA5{vvvv.exe } MainLoop.TMMainLoop.DoTimer (Line 208, “MainLoop.pas” + 27)
0050CB9A{vvvv.exe } IdleTimer.TMIdleTimer.AppIdle (Line 165, “IdleTimer.pas” + 46)
00480B35{vvvv.exe } Forms.TApplication.Idle
0047FFA7{vvvv.exe } Forms.TApplication.HandleMessage
0048028F{vvvv.exe } Forms.TApplication.Run
008A6FCD{vvvv.exe } vvvv.vvvv (Line 24, “” + 7)

Call stack for main thread
Stack list, generated 2011/12/20 11:41:18
77810C42{ntdll.dll } ZwGetContextThread

System : Windows 7 Professional, Version: 6.1, Build: 1DB0, “”
Processor: Intel, Intel® Core™2 Duo CPU P8700 @ 2.53GHz, 2533 MHz MMX SSE SSE2 SSE3 SSSE3 SSE4A 64 bits DEP
Memory: 4095; free 1643
Display : 1366x768 pixels, 32 bpp


Active Controls hierarchy:
TAddFlow “AddFlow”
TPanel “AddFlowPanel”
TMViewPatch “MViewPatch_0”

tested with alpha26.1 e1ec9a1299
cheers!

happens all the time, specially when you try to select and play animation