Pillow edge is not transparant

So, I have this original (ahem) way to make a slideshow, I got some pillows floating in 3D containing a piece off a picture, and than they come together to form the entire picture (how genious is that?? ;) )

Works great, looks cool.

So I figured, I add a background to make it look cooler…

But ahh… why are the edges off the pillow not transparant, even when I set the alpha to 0?? No I got ug black squares arround the pieces off the picture.

I attached a patch just for the pillow problem (need to clean the patch up before I post it ;P )

Hope I missed (yet another) node or something…

Pillow in space stays square.v4p (6.7 kB)

depthbuffer to none and blendmode to add…not sure if this is what u want.

Pillow in space stays square2.v4p (7.3 kB)

Ahh… I forgot about BLEND, thnx u7.

Where can I find the depth buffer, so I can set it to 0 ??

It works nice when only using Pillows or Quad, but I tried an .FX file as background, but then that ugly square look comes back.

So I have to do my best to make a simple ‘pillow based’ background that still looks good. Hehe… can’t have it all…

check herr inspektor after selecting the renderer. there u have a depthbuffer setting for window and fullscreen mode.

and it should work with an .fx too. it depends on the texture as add mode means additive. so colour information is the important bit.

and of course you can setup images in photoshop with alphachannel and save them as png.