Phong 9vs11 render question

how can i make the dx11 phong look like the dx9 one ? not sure what the difference here is … normals ?

yea this is normals
there is FaceNormals.gsfx in packs\dx11\girlpower\sm4\streamout\PerFaceNormals
you can pass your mesh thru it to fix it

FaceNormals does not seem to work as expected, less so with mesh subsets
normal question (4.5 KB)

yea that’s not gonna work with subsets like that (it’s still possible to do but you will need to modify shaders)
the easiest will be to re-export your mesh with flat normals

i think it happens actually when there are no normals in the file, and assimp generates them on fly (2.2 KB)

can you describe what you did to the mesh ?
im a bit stuck in rhino with the procedure, i got this sugestion but it seems very hacky for obtaining what was dx9 default behaviour

Offhand, I would say you want to use Unweld with a value of 0 - which will visually do what Flat Shade does - then if you have internal joints at a low angle that you want to hide, you can re-weld with a small angle like 10°…

pff, i have no clue how rhino works ;]
looking on to this
what that link says, if you vertices merged together then you will have smooth normals, if you separate you wont have that anymore…

well what i did is imported your 3ds to 3d Studio Max and saved it as OBJ with normals option

try this maybe… normal question (6.4 KB)

for rhino, saving .obj passes on normals in the expected way, .3ds does not

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.