Parallel port active for no reason


I’ve got a problem with a parallel port: I’m trying to control some lamps with relais connected to the parallel port (greetings and thanks to the pacmatch-team!).

I successfully built the controlling patch and tested it. It worked smoothly. Now I moved the device and patch to our server and it doesn’t work anymore.

Usually all lamps are off unless something is written to the parallel port. On the server, all lamps go on as soon as windows boots - before vvvv is even started. Resetting the lamps with my patch doesn’t work either. As far as I can tell (I didn’t built the device myself), something is writing to the port, because otherwise the relais wouldn’t switch the lamps on.

Does anyone have an idea what is going on? I already tried a registry hack (Parport\Parameters:DisableWarmPoll=1), but without success. What am I missing?


using the port node in vvvv uses some really historical technology. basically it allows you to control things in the same way you could have done that 1981 with the first orginal IBM PC. that it is still somehow working is one of the miracles of windows and the pc platform.

if you use this trick from 1981 you will bypass everything windows knows about printers and directly shoots bits down to the metal. note that windows itself will not know anything (or can do) about your attempts. it also will not inhibit other processes from doing things to your port as well. so in your particular case i suspect some printer manager silently sitting in your windows installation has misconfigured your printer port.

so try to deactivate the parallel port in the windows system settings. you may also like to boot windows in debug mode and loading all drivers after another to see which driver is exactly responsible for accessing the parallel port

After changing about every configuration option, killing almost every process and digging through countless FAQs I finally found the solution… which embarrasses me a little:

I forgot to copy io.dll to the server. So vvvv couldn’t send my data to the port. doh I still don’t understand why it was active in the first place, though.

Thanks a lot for your support! And sorry for being so clumsy…