Forum

OSC Decoder fails to decode a string

Hi everyone!
I haven’t found any relevant info on forum or web so i have to ask for help.

So, here’s the deal:
I need to send and recieve some data between vvvv and Unity on different machines so i learned about OSC protocol that vvvv is gladly equipped. I managed to send strings with time and some cosine wave values at decent rate to my laptop via UDP messages broadcasting to my home network, but when i tried to send some generated textures to other PC i stumbled with a problem that OSC Decoder won’t decode that encoded texture. You can see that it is not a UDP problem on a screenshot below.

So, do you guys have any clues or maybe there is a workaround for this type of messages?
I run beta 31 on PC and beta 31.2 on laptop, both 32bit on 64bit Win7 - problem seems to appear in both versions.

Also, small question: How to change argument type in OSC Encoder? Changing type tag don’t seem to work, node still accepts only string input.

-Cheers from Russia!

i guess you have to check which encodings are used by sender and receiver and make sure that they match.

tonfilm, How do i do that?
I don’t think this is an encoding problem because decoding fails even within one path straight from OSCEncoder node.

as the nodes helppatch explains it only understands s, f and i as typetags all of which you have to specify as strings but are converted to float/integer for sending respectively.

to my knowing there is no standardized image format for osc and as mentioned above vvvv would not understand it. so maybe consider just to use raw udp for sending textures. would you really need the osc-overhead?

Thank you alot, joreg!
Although i never got OSCDecoder to work with encoded texture, pure UDP seems to work fine for streaming small (200*200) video or handy vector matrices!
And i understood how to send numbers with OSCEncoder too.

Have a good day!
Vladimir