Forum

Openni kinect in beta29.2


#1

hi

kinect openni nodes perfectly work for beta28.1 with following drivers:
OpenNI: 1.5.2.23
PrimeSense XnVSkeletonGenerator: 1.5.2.21
PrimeSense SensorKinect: 5.1.0.25

but they aren’t for beta29.2.
Kinect node see no drivers (string with empty string, not nil, no error messages, empty tty and so on)
Miscrosoft version works perfectly, but i’m prefer Openni at the moment.
Please advise with proper drivers, if possible.
Thank you


#2

https://discourse.vvvv.org/t/9756


#3

@metrowave microsoft nodes work fine, but i need openni, since player(user in openni) is tracked faster with wide lens on kinect. openni work fine in beta28 in same system with same drivers.

guess, i must renew openni drivers, but i tried different from openni.org with no succes


#4

hmm, cannot confirm.

i just tried with b28.1 and b29.2 (on the same pc) and both work with the openni-drivers you mentioned (which i installed about a year ago on this pc). also nothing has changed with the openni-nodes. they only still work with exactly those drivers, thats the idea.

do you get anything in tty?


#5

@joreg
thanks for helping.
i can confirm, this is unsknown driver problem in my current system.

i tried 7zip, unregister all previous version, use other usb-ports, use other kinect device - nothing help. i use other pc with same setup - work perfectly both in beta28 and beta29.2

on wrong pc for beta29.2 tty said only when plug/unplug device
00:02:27 - : enumerating game devices
00:02:29 - : enumerating game devices
00:02:30 - : enumerating game devices
that’s all

it’s kind a karma
will report on fixing


#6

Same problem here. Kinect OpenNI drivers and nodes work well on b28.1_x86. With a29.3_x86, b29.2_x86, b29_x86 they don’t work. Microsoft version works perfectly but now I prefer OpenNI nodes.

@@joreg: I also played with OpenNI and b29.2_x86 using the same drivers that I installed a year ago. Then I uninstalled OpenNI drivers, installed MS driver to test it and then installed back OpenNI. After this process I notice this strange behavior.

Attached 2 screenshots.


#7

k, the problem with the openni nodes is the following:


Kinect red node again
#8

Hi,

I am an experienced C#/Java developer, over 12 years working with this stuff.

I can help write the new wrappers if I get pointed in the right direction, Who should I contact in order to help this get moving up?

Thanks.


#9

great. well, you start here: vvvv sdk and there dynamic plugins

then i suggest to check the sources of the current openni implmentation:

then i think i’d go for this wrapper http://www.openni.org/files/niwrapper-net/

and come onto irc for faster exchange of info regarding this…


#10

Hi all
This strange behaviour just happened to me on a laptop,
Really strange!!! Since i need the opencv openni for calibration
I’m stuck!
Any news on this?
Take care

ps: driver issue with beta > 28.1
ps2: tested on 3 desktop machine no problem… issue appear only on the laptop (win7x64 family)