OpenCV - ImageReader Crashes on hovering output pin

Hello, I am using VL.OpenCV v 2.1 on gamma 2021.4.0 stable release.
When I am trying to start a link from the output pin of an ImageReader (as soon as I hover it), VL is crashing.
This behavior reminds me a lot a similar finding on Stride’s widget for observing an object with multiple meshes, can these two be related?
Does anybody else noticed this behavior?

Did a quick test from your description and no crash. So please upload a patch showing the issue.

works here. no crash

hm what might be wrong then ?
sorry for the awful quality I did the conversion on the fly

2021-12-06 18-49-20

@Elias & @schlonzo did you try guys to load an image ? I know sounds silly but this is when this thing occurs

Did the same steps and still no crash - and yes, loading a 4K jpg file. What does the windows event log say? Any crash-callstack you can post here? And just to make sure, also try with a clean packages folder - simply backup your current one, install vl.opencv once more and see if that still crashes.

1 Like

@Elias yes I understood what was causing this (probably) I had an older version of OpenCvSharp and its runtime in my nugets folder. After I removed them everything worked as expected.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.