One of the first Leap isnt dectected by 34.6 and VL plug in

Hello dear vvvvriends !

I have one of the first leaps distributed some years ago to volunteer developpers.
This device is working correctly with Leap in VVVV 34.2.

It shows correctly in the actual leap motion app, giving graphics of the hand etc…

But it isnt detected nor working in 34.6 (x86 and x64) with VL plug in

Does anybody have any idea on how to solve this ?

hei karistouf,
first: there is no b34.6.
and: which VL plugin are you referring to? and which leap driver version do you have installed?

Hei joreg :)
nice to read you :) long time :)

40b34.2 x86 is what i have on splash screen

About driver:
Orion software version: 4.0.0+52173
ID Leap controller: LP94316150737
Firmware Revision: 1.7.0

about plug in: when i open in node list Leap(Devices) i have a VL thing loading things … . So i presume that the Leap Node is coded with VL, wich was not the case previously . yes I know, i never go inside VL, i m an old patcher like Kalle, forgive me

edit : i didnt install the SDK, only the driver

heiho karisto!

i’m not exactly sure how you’re seeing anything VL in b34.2, because VL was only introduced with b35…

anyway the problem you’re seeing was introduced by leap: they had a breaking change in their drivers. with 4.0 orion you’re using their latest, which is no longer compatible with the old sdk used for the vvvv nodes.

so you have three choices:

hello joreg, thanks a lot.

  • b34.2 is working ok with my leap and the actual last driver. there is no VL. i agree i was not clear

  • recommended: old drivers are not detecting my leap, i presume that i surely have accepted a firmware update. im reinstalling leap motion setup with Orion up2date in 4.x version and not 2.3

  • VLDevicesLeapOrion: a lot of Red Nodes. Setting up VL dependencies and nodes missing is quite obscure to me

  • conclusion i will ask microdee… thank you for your help

why are you not choosing this option then?

Because i m using DOPE, DX11 and triangulate 2d contributions

i’m afraid that doesn’t explain… you said you want to use b34.2x86 and then you said it works. maybe try to be more specific…

Sorry i cant use previous versions of VVVV for the leap part, as Dx11 / Dope and 2dTriangulation contributions are not working with it.

The set up of VVVV is this new project is OK for images, but not for my old leap…

@joreg. Ok i donwloaded latest alpha. just can you tell me how to install properly the github VLDevicesLeapOrion: i m trying to install VL dependencies with right click but it doesnt find it.

Thank you for your help

sorry, i shouldn’t have suggested this option, because it is not ready for easy use yet. atm this still needs you to build the package yourself (see \src folder). thats why i called it experimental. i’ll wrap it up and finish it at some point but you probably don’t want to wait for this.

oooo joreg, no compilation no more for me. too much time in my previous life for hard / bad coding ! i will wait for any other solutions showing up

i have tried to launch 2 instance of different VVVV: the 45b34.2 and 50b37 without success

is there anyway to achieve this, i could be able like this to send in TUIO or OSC the data of the leap from one to another instance.

All has to be done on same computer.

Thank you for your help and time

Maintaining VL joy… that’s one of the reasons I still do c# instead of VL.
This just a guess but:

i guess

next i don’t really know what to do, maybe there is example patch on git somewhere (58.5 KB)

Grumph… this VL thing is really a nightmare when you dont know or master it… dependencies and install troubles are really frightening…
thank you Antokhio, it doesnt helas worked…

i need now to find HOW to use 2 different VVVV on same computer …

how have you tried? the way to go is using commandline option /allowmultiple to run the second instance.

thank you joreg,
ok, well its really weird…

  • setted 45b34.2 x86 allowmultiple
  • setted 50b37 x86 allowmultiple
  1. I open 45b34.2 with leap patch > hand detection works
  2. I open 50b37 blank vidéo > hand detection in 45b34.2 automatically deseapear
  3. I close 50b37 > still no more hand detection in 45b34.2
  4. Hand detection is crashed for 45b34.2 until i restart computer

should i buy a new leap ? or is there anym magical code or conf to do somewhere ?

what do you mean by that? i can imagine leap registering as VideoIn device and if you select that on another instance that it causes such problems.

Sorry Joreg: i mean by blank video NO hand detection. i m not using videoIn. im just about the leap node

EDIT: ok i have worked around and yes know its working, i have a 45b34.2 with leap working aside 50b37. I dont know why it was not working this morning, but now it does it.

i still dont understand why this leap is not taken by the VL coded part of VVVV 50b37. it would really be great to have everything working with only one VVVV… i presume command exe will be my friend :)

Thanks a lot joreg for your help. Have a nice night