Forum

One more error message

Hi people, pretty often vvvv crashes (kernel32.dll is involved) then this message appears

Exception EInvalidPointer in Modul vvvv.exe bei 000046C1.

Does anybody know what it means?

Cheerz,
Alecz

this is pretty unusual. please post a minimal patch when this happens to see whether the problem is related to a specific node.

note that vvvv will utilize all your computer parts to the maximum. so make sure that all fans and heatsinks are working correct, double check any connectors (RAM, AGP etc.) and make sure all your graphic, network, motherboard drivers are up to date and your system is virus-free.

This problem has been replaced by another one, sometimes a message appears saying “Exception EAccess Violation in Modul vvvv.exe”… I have just reseted registry based to zero… But the problem may comes from a virus (I’m scanning with Stinger)

Hi dudes! Here we go again!

OK, some news: I tested my RAM my memtest and it returns many many many errors. After googling, I found that the only solution is to change the memory…

I currently use 4x1Gb G Skill memory (800MHz), what RAM could you advice?

Thanx a lot,
Alecz

Hi people,

On Digital Slave’s advice, I flashed the BIOS and everything seems to be normal again…

So I guess the trouble is solved.

Thanx again everybody,
Alecz

Yo people, me again,

I just discovered all those error messages (einvalid pointer, eaccess violation) are due to a .net runtime 2.0 application error. I saw that in the event log (in application tab, system tab reports nothing)… I have .NET Framework v1.0.3705, v1.1, v2.0, Compact Framework 2.0 SP1, Microsoft Visual C++ 2005 Redistributable.

Event log says:
Source: .NET Runtime 2.0 Error Reporting
Categorie: None
ID event: 1000

“Faulting application vvvv.exe, version 4.0.16.0, stamp 2a425e19, faulting module unknown, version 0.0.0.0, stamp 00000000, debug? 0, fault address 0x00000000.”

Another one says:
“Faulting application vvvv.exe, version 4.0.16.0, stamp 2a425e19, faulting module vvvv.exe, version 4.0.16.0, stamp 2a425e19, debug? 0, fault address 0x0002bf50.”

And a last one:
"“Faulting application vvvv.exe, version 4.0.16.0, stamp 2a425e19, faulting module kernel32.dll, version 5.1.2600.5512, stamp 4802c25e, debug? 0, fault address 0x00012aeb.”

Do you know what all that shit means?

hi ars,

those errormessages alone don’t help us much. if you can provide a simple patch that causes those errors we are likely to be able to help.

Hey joreg,

I understand, but the problem is that those errors are very erratic, I can work for hours on big patches without problem and have a vvvv crash with a simple patch…

I’ve been working without .net (v1 or 2) a few days ago and everything worked fine. Now I’ve installed .net, errors occur again, but since I flashed my mobo BIOS, problems happen less often.

I’m sorry for not being able to provide more clues. I think I’ll try with .net v3 and, if errors remain, uninstall .net.

Anyway if someone has information about relation about .net and vvvv, I would be interested (not sure to dig everything but I can try).

Thanx for your patience

vvvv utilizes .net2.0 only for its \plugins. you won’t need .net at all for vvvv if you’re not using any of the \plugins.

there is though a problem still, that would not allow you to use any of the \freeframe, \vst nodes if you don’t have .net2.0 installed. you wouldn’t be able to create those nodes at all, so this may not be your problem.

if i understand correctly .net3.0 is something completely seperate. installing it or not should not interfere with vvvv at all, nor do it any good.

I see… that’s ok for /plugins I don’t use them, nor /vst. About freeframe, I don’t use them much. Actually I need basic functions…
I’ll let .net 2 on my 2nd PC only, to use timeliner…

Thanx a lot man, I can sleep now! ;)

Cheers,
aR

PS: anyway, if I can find further information about my .net provblem, I’d let you know. Can be helpfull.

For instance, this patch has made vvvv crash at open.

essai grrrrid.v4p (64.2 kB)

this patch as is works for me. but it is missing a major subpatch…

Oh yeah, I surely may forget something… but I’m pretty sure it would work perfectly for you, even with this subpatch. As I told you, the problem could happen only once and never again.

Yo joreg,

This is the full patch… not sure you can experience the same errors as I.

essai grrrrid.rar (7.5 kB)

Hi people, I’m back again!

I have uninstalled .NET 2 to avoid bugs but gregsn wave02 crashes everytime with the usual message EInvalidPointer. The new thing is that TTY returns the same errors endlessly and when I click on pix wave shader, inspektor returns nothing, even the name of the shader is replaced with an “?”…

After searching the web, I discovered EInvalidPointer is a problem of memory allocation but I don’t know if it comes from the memory itself or from XP config.

bug.jpg (237.3 kB)