Forum

Nuitrack + Realsense D455 not (always) working

Hi there,

I’m having problem getting any output from Nuitrack nuget with Intel Realsense D455 camera.
I followed installation instruction [here] (https://github.com/vvvv/VL.Devices.NuiTrack/blob/master/README.md) and got the example working with 32bit installer and trial license.


But when I use Nuitrack node in vvvv gamma I don’t get any visual result. On a different machine with same vvvv version (2021.3.3) it works though !
What am I missing here ?

thanks!
jib

did u try open help patch? does it have some red nodes?

works for me im using VL.Devices.Nuitrack -Version 1.2.0

@khakubiya yes I did open the help patch, no red nodes, the render shows only grid & axis witthout point cloud.

try using the last preview build maybe

got the same result with latest preview build - render without pointcloud.
I wonder is there a special configuration to make… I vaguely recall someone mentioned a config file inwhich you can specify the camera but I cant find the source

when you open the “Overview of available nodes” patch that comes with the nuitrack pack, you see it talking about that config file:

1 Like

Thanks @joreg ! I looked into the config file but not sure the solution is there. I start to think that the problem is with my Nuitrack SDK installation because it doesn’t recognize other depth cameras as it should (on the other machine I tried with the same cameras and everything works fine, both with SDK and with vvvv)

I’m now using SDK 32 bit version because when I try to get 64 bit running I got error “Entry Point non found error” even if the installation is complete and the dll file is there.
Cattura2
Anyway, I’m digging this issue for couple of days with no luck so I think I have to find another machine to use !

There was issues with openNi and Kinect SDK installed on same machine, looks like you ran in to one of this kind of problems, suggestions:
Uninstall all possible depth camera softwares you have installed… Reboot and install the nuitrack

1 Like

Thanks @antokhio I tried to uninstall depth cam softwares (actually only Kinect and nuitrack), reboot then install nuitrack but no succeed still… probably there’re other softwares, apart from depth camera ones, that can create conflict ??