Noob, can't see my collada mesh in the renderer, even if I open a help patch with a mesh that works and swap in my file path

Been through the 40 or so tutorials, great stuff. I even got my sound card eventually to play nice for the audio reactive stuff, nice!

Here’s my problem. I’ve been 3D modeling for decades, about 10 years with solidworks, so I can create some cool stuff. I was able to find a way to save solidworks as .stl, then using meshlabs save as .dae. Also translated another with an online upload converter service, both methods open the dae in photoshop, so the files are at least “good” though I’ve inferred maybe vvvv has some problems with .dae?

So I’ve opened a help patch with a working mesh and swapped in my file path and the renderer goes blank.

Any suggestions? Scale may be a problem, but in other software the models open together intersected and the scale was one about 10x bigger, but could easily see them both.

I’m just dieing to import some cool geometry into vvvv, I’m just doing something wrong evidently! Help!

As they always tell me, patch and model, please.

If you are in dx11 make sure to set no texture in technique for the shader, stl won’t have any uv map so u are having missing semantics in the model.

There is error pin on the bottom side of the shader also.

And I’ve would use obj as a starter
But stl should work out of the box in dx11 too.

I see the “up and running” pin, is at 0, don’t know how to interpret any detail out of that though.

That said, I would think all the settings correct, as I’m using for a template a help patch that works with the superhero model before I swap in my model. I tried multiple models btw, none successful, though all opened in other software. I was thinking maybe just a lack of texture/color issue, but expect that would just come in gray, not invisible. Thoughts?

Is your model exported with a material assgined on it ?

I looked and did not see any export options at both exports, didn’t see anything about baking/flattening etc. The original solidworks did have surface art. Upon import, if I recall correctly, in meshlab both the note5 and the vvvv superhero boy looked uncolored light gray. Opened in Photoshop I think the boy had color, the phone was blank gray. So I think export to stl strips all graphics, which makes sense because it’s intended for stereo litghography (STL?) no?

The model it’s there, just not in the center of the screen.
Put its origin axes in the middle of the model, so it’ll be centered on renderer.

hammerhead.v4p (7.8 KB)

Here you see how its “centers” are set to what the half the XY sizes of the model seem to be.
Please also check the inspektor for renderer dx9 settings.

For the tex mapping you should export a mesh for each tex, cubic mapping. With collada you would then have multiple submeshes, each with its own tex. You should be also able to use different fx for them via getslice (node), giving you more flexibility for what materials appearance should be.

Thanks H99 for the reply and for the tex mapping technique, I’ll use that I’m sure!

I opened your patch and don’t see the note5 hammerhead model still, does it show with this patch on your screen?

Experimenting with your patch, controlling the camera around (can someone tell me how to mouse control the camera?) with the pins and adding various objects to create a camera rotating scene for reference, still no luck with the note5 hammerhead, but the superhero works. I duplicated the filename node and pointed it to the other file, so I can reroute from pins of each filename node to colladafile node, back and forth, same result each time.

Then an interesting thing happened. To send back my modified your patch, I clicked save, and when it gave me that warning question, reload or don’t I know what I’m doing, I clicked reload then the superhero disappeared from the renderer at that reload. So maybe my mesh files are in the wrong location or something?

Ok then I went through it again repointed the path for superboy, that worked, so I tried it for note5 and it worked! Not sure what I did differently though!

The important thing is I now verified it can work in my hardware software setup, sweet!

Thanks for the help!

Be sure that each filename you input is correct. Until you get used to vvvv, copy\paste folder path and add file, or what you prefer.

If you have some time, I’d like to talk to you about our Lord and Saviour, who left us thousands of line of code that can be downloaded here.

Ya thanks it’s all copy paste or browsing to the file itself for me.

The download I’m thinking is included in the add-in pack? If so I installed it same day last week as vvvv Or is it something different?

Oh, no. Our float4 Lord = Saviour != theSame.
You must take a pilgrimage to the location I already mentioned, where you’ll be able to ask for the gift. Beware! What you ask for, is to be what you need! No more, no less…
Now travel to the very sanctum of our faith.
In the very first room, in the same room of the altar, you shall place a box with the mystic inscription “packeth” on it. Then you shall expose the gift to the light, and then place the gift in the box. Return back to the altar: begin the sacred ritual and search in the hallowed book the name of the gift itself, read those pages and finally meet the light.

In case you’d prefer a less esoteric explanation, follow the link, download the stuff for your architecture (x86 or x64) and browse to vvvv folder. Here create a folder “packs”, extract the content of download with 7-zip into “packs”. Now run vvvv, type dx11 in NodeBrowser (the double left click panel), hit f1 for any dx11 node, enjoy.

EDIT: it is possible that dx11 nodes come already in “packs” folder. In that case you obviously don’t need to create such a folder.

Uh, okay, it’s an honor to be worthy!

In celebration I made DX 11 randomly floating donuts!

Ah, hope you had some fun with that silly post.

We have all been there. Also, if you need help, make a new prayer, I mean, a new thread.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.