Nodes not resolved correctly

This just happened, the patch was created with and older 2022.5 preview and then saved with 588

this is the diff when it was saved with 588:

Can’t reproduce it. What I tried:

  • Start 4.12, reference both Stride and Skia, create a PointLight node from Stride and save. Then manually modified the saved file via xml editor to look like in the screenshot (adding LastDependency=“VL.Stride.vl” and removing the category choice).
  • Opened that file with latest 5.0 and all good.

Did maybe the reference to VL.Stride go missing at some point during your development? Either because VL.Stride was broken / missing or is VL.Stride coming in through some reference forwarding which collapsed and subsequently the Skia PointLight (being the only one available under that name) was resolved?

That sounds like a possible scenario, although I think it should not be resolved, and the node should stay red and not update it’s reference on save. This can lead to a lot of broke patches.

But if this theory is right, it should be possible to remove skia so that the original node is the only one available… I’ll try that.

removing skia temporarily worked. the diff after saving then looks like this:

adding skia back after saving the file worked too.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.