Forum

Node namings

Sven Bauer wrote:
Hallo Sebastian,
im Zuge eurer momentanen Anstrengungen, VVVV und alle Begleitelemente transparenter und schneller fassbar zu machen, möchte ich hier noch mal anregen, die Benennung der Knoten erheblich radikaler zu strukturieren. Bitte denkt doch noch einmal darüber nach, die beiden Elemete eines Node-Namens klar ihrer Funktion nach zu verwenden. D. h., was in Klammern steht, gibt unmissverständlich den Datentyp des Haupt-Inputs an. Also z. B. “LinearFilter(Value)”, “GetSlice(Value)” oder “SplitVector-3D(Value)”. Abstrakte oder irreführendeBezeichnungen fragmentieren die Oberfläche zu sehr, insbesondere, da alle Befehle auf einer Ebene liegen.

Zudem wäre es ganz gut, den “Decay”-Knoten endlich in “AR-Envelope” oder etwas ähnliches umzubenennen, da die Bezeichnung schlicht falsch ist. Ich finde diese Anpassungen umso dringlicher, je komplexer der Funktionsumfang von VVVV wird.

Beste Grüße, Sven

Ja, gutes thema; altes thema.

nach dem vorschlag wird es extrem viele knoten in der kategorie value geben. ich weiss nicht ob sofort zur übersicht beiträgt. sinn der kurzen knotennamen ist, dass die patches übersichtlich aussehen, gerade auch weil nicht alle semantischen details (vector oder nicht?, 3d oder 2d?) angzeigt werden. insofern war es eine bewusste entscheidung
Split (Vector, 3D, Value)
eben genau nicht
SplitVector-3D(Value)
zu nennen.

Klar ist, dass die knoten-auswahlmenüs und die tooltips überarbeitet gehören, um die bedienung zu vereinfachen.
klar ist auch, dass “Spreads” eigentlich genau “Value, Spreads” meint, und das die leute verwirrt. hier müsste jeder knoten mehrere kategorien geben, und die knoten müssten ggf. mehrfach auftauchen.
natürlich gibt es auch viele knoten die sich keinem Datentypen zuordnen lassen.

mit Decay und AR-Envelope hast du recht, aber AR-Envelope klingt nicht recht prickelnd. vielleicht nur Envelope?

Eine große Anzahl von Knoten wäre kein Problem, wenn man es schaffen würde, eine Vertiefung der Selektion anzubieten. Aber klar, bei der momentanen Struktur des Interfaces verlagert man das Problem damit nur.
Was aber, wie du selbst bemerkt hast, akut stört, ist die Kategorie “Spreads”. Die dürfte es konsequenterweise eigentlich so nicht geben.

Zur Envelope: Es gibt ja schon ADSR. Richtig wäre also AR, klingt aber doof ; )
Sowas wie “Inertia” vielleicht. Ist dann allgemeiner.

allgemeiner, im sinne von verwechselbar mit Damper Oscillator Deniro? :)

Naja… zumindest weniger allgemein als “Envelope”. ; )
Vielleicht fällt euch ja noch was passenderes ein. Bin gespannt… :D