Forum

No AudioIn Drivers

Apologies for the extreme newbie question. I’ve been following West’s fantastic beginner tutorial series, but am stuck with #26, the sound reactive rope. The problem is that the AudioIn and AudioRecordSelector nodes are red in the BeatDetector help file, presumably because there is no driver input. When I try to change the driver input, the only option is (nil).

I’m guessing vvvv is not detecting that I have a soundcard (onboard), but don’t know how to make it detect it.

I’ve had problems with other programs detecting audio before, but it does play out sound, and works with most programs. Is there any way I can look at how vvvv is going about looking for a soundcard and tweaking it to the right direction?

It shouldn’t matter too much, as I’m getting a new laptop next month, but I’d like to solve this in the meantime.

Many thanks

Hi
what about model of laptop and soundcard? Have you installed the right drivers? Which OS ? Does it show yup in the Audio Preferences?
S.

Hi io,

It’s a PC, Compaq Presario SR1909UK. The soundcard model is hard to find. I know it’s RealTek, but it’s only listed in my system as ‘High Definition Audio Device’. The drivers are apparently all up to date (just re-checked now). I’m using Windows 7 Home 64-Bit.

Are you talking about the audio preferences of vvvv? If so, how do I access them?

Thanks

No just audio preferences of WIndows, have you started vvvv as administrator? Have you checked that crack.exe is fine?
S.

hi, it’s maybe the problem of the hidden stereo mix. check in windows sound pannel control for it in the “Record devices” tab or something like that (i have not an English version of 7 so my translation could not be matching exactly…).
If you can’t see stereo mix but see only line in or mic stuff, right click in the void and check display desactivated devices or something like that. Then stereo mix should appear, activate it if it’s not and you’ll normaly be able to use it in vvvv.

of course after restart of vvvv.

I had this same issue today, and this is how I fixed it for WINDOWS 7:

Move to the Control Panel/Hardware and Sound/Sound. Click on the Recording Tab and make right click in a blank section and check the option to show disabled devices. If the System Mixer is there, choose it as the default.

I am also (a newb) having this problem with windows 7. In my case AudioIn was not red but would not let me select any driver other than microphone. AudioOut was red but I was able to change the driver. Unfortunately the solution above did not work for me (after enabling show-disabled-devices nothing appears). Any other ideas?

its asio cards i guess try search for asio topics

Guest, Westbam and others; I have had similar problems with Tutorial 26, and anything involving the Rope Node. I’m running Windows 8 on a HP Pavilion dm1.

just a side-note: the Rope (DX9) itself was broken in b29_x64 but is working again in b29.2_x64

Thanks joreg. I’ll try updating to b29.2_x64