Newbie and his midicontroller

Hi vvvvorumers,

I just started using 4v and it looks really really interesting :)…
So I got a quick newbie question, I wanted to use a evolution x-sessions UC17 midi controller. It seems like working on XP with the software supplied by Evolution…
But in 4v i created a midicontroller node and i can see it as a midi input…
But i just can’t get output from the controllers.
I read the documentation on this site about midi controllers and I dont think that I’m doing something wrong…
What should I do? gulp


v4’s channel go from 0-15, so if your using channel 1, set v4 to ch 0, controllers are number nore rationally I think!
If that isnt the problem, then I dont know!

i tryed the X-session controller whit4v.
it ususlly works fine.
that is a simple patch with which i use it.
hipe it’s useful.

file… no text …

controllerX-session (devices).v4p (16.8 kB)

thx for the patch solanina,
I tried it but it seems like I can get values only from
the slider and the other buttons doesnt seems to be working for now
I’ll try to update the drivers for X-sessions.
I’ll keep you posted :)


I updated the drivers but i can only see
the values of slider and
2 more buttons.the rest is not functioning :(
any ideas?


hey jamsaver any luck on that? im using the same midi surface with the same results… oh it would be so sweet if this works

Well, I am trying to use an M-Audio O2, but to no avail… tried the pacth from Solanina and I am not getting even the slightest message from the interface. Anything I am missing here? Like JamSaver, I’ve spent some quality time reading the manual and trying to make it work before crying on your shoulders… :) Any help greatly appreciated! Cheers, Cass

the attached monitor patch shows the input actions for all midi controllers on all midi channels. open it, select your midi device and then turn some buttons to see if anything comes in.

MidiControllerMonitor.v4p (3.8 kB)

thank you for this usefull patch tonfilm,
i tried to use stallone (spreads) to get separate values of each controller but it doesnt seems like working, what should i do? :)any idea?