Multiple capture cards maybe an issue?

Hi guys,

Strange result make me think that our hope are not so impossible.

What do I want?
Use of 2 or 3 differents capture cards to display on an unique and same renderer.
I’m looking for state of the art result: 50fps Progressif to be display on professional DLP projector. Fluidity of the renderer when something happend inside and outside.

Our problem was:

  • no fluidity with multiple capture in my patch
  • strobe in the video captures
  • renderer framerate not realy stable

For the 3 problems we have found ways to cancel them but in some cases only.

  • for the fluidity and the renderer stability: the use of a mainloop node(Foreground 200, Background ?, Increment) this solution work efficacely but everything make more time to happend in the renderer(it is normal according to me).
  • strobe in video:
    *capture card are 2 videos 25i (interlaced)
    *and 1 graphic vga 25 fps (progressif)

**for the videos we use DScaler and a wait for frame of 1 frame.
**for the graphic we have set the wait for frame to 2 frames.

In a simple patch with capture patch only, everything is ok
In a bigger patch we have to do some strange things:

step 1: set the DX9 RENDERER in fullscreen
step 2: using CREATE NODE node : create a first video capture patch with VIDEO IN node Disabled in a first time
step 3: using CREATE NODE node : create the graphic capture patch with VIDEO IN node Enabled.
step 4: using a KEYBOARD node : finaly Enable the first video capture VIDEO IN node.

In result: with two differents capture everything can be
fluid(for almost a few moment).
Impossible to have this result going directly fullscreen with every VIDEO IN nodes created and enabled before . Why?

According to me video strobes comes from that the renderer himself strobe.
What is the strobe visual effect? It’s the continuous repeat of previous frames when a new and a next one is expected.

Is there a way to insure the non strobe of the DX9 renderer? A kind of Cheater Node for the renderer.


The strobes arent from using a video texture YUV node are they? I’ve had issues with that and flashing frames, the normal videotexture node seems to work fine ie Iv’e never noticed strobing…
I’ve had multiple ins work ok too, but they were off one card rather than multiple capture cards. Also for deinterlacing I’ve been setting capture resolution at 720x288, effectivly loosing 1 field, gets rid of jaggies and also it lowers bandwith.

I khnow the flashing frames issue of the YUV video texture. Thank’s. I’ve already banned the use of the YUV video texture node.
I’m going to try to set capture resolution to 720x288. Which deinterlacer do you use? Freeframe or DScaler?


I dont, I think it just looses 1 field, it certainly doesnt exhibit any artifacts, just looks like a progressive frame, like capturing 360x288 but higher res!

halo thiv.

i have not answered so far because this is really an endless topic hard to discuss always depending on what depth we enter the discussion…anyway i’ll try something:

in theory you should never get smooth output with your current setup since it is not synced. you are using 3 different inputs + 1 output that are not synced. so they all run at 25 or 50fps but nobody tells them when a frame starts. professional cameras and graphiccards (i am not sure about the vga-grabber though) can take an external sync signal which they adjust too. this way they are all synced and the theoretical foundation of smooth live-video-throughput (from camera to projector) is laid.

having said that you should now understand that all following discussion is kind of esoterical.

one thing i have not yet figured out is if the “Multithreaded” option in Device (EX9 Auto) switched off has influence on strobing with the VideoTexture (EX9.Texture VMR9) . if not switch it off for a possible overall performance increase.

my best bet for settings with your setup:

  • all VideoTexture (EX9.Texture VMR9) “Wait for every Nth frame”: 9999
  • MainLoop (VVVV) “Foreground FPS”: leave at default (120)
  • Windows Monitor Driver: set refresh rate to 50Hz (therefore you’ll probably need a tool like powerstrip)
  • pray (to what ever you believe)

now make sure that with Renderer (EX9) “Presentation Inverval” set to “Immediately” your framerate is still higher than 50fps. if not reduce your patch until you have >50fps. then go for the last setting:

with those settings the renderer should sync to the monitor and so should to vvvvs framerate.