Forum

Midi IN - from digital piano (88 keys)

Hey there,
I’m kind of a vvvv newbie. My problem might be pretty basic, but at the moment unsolvable for me. Many thanks in advance for your help.

Problem:
I’m trying to get the input data from my digital piano. I use the USB-Midi-Interface Uno 1x1.

Note:
This is NOT a driver problem. I can work with the midi input in Ableton. And in vvvv I also can send midi output signals (triggered by keyboard) directly to my piano. The patches from Kalle do a great job. http://vvvv.org/documentation/kalle.modules.midi

See attached a screenshot, where I tried to get the input signals of my 52 white keys.

and again: I appreciate your help!

Why do new users always post a screen shot, and not a patch? No critic, just a question… I see this a lot!!

Really, a patch is like 10kb, that screenshot is over 130kb, and in a patch we can see and change mistakes.

I find MIDI and vvvv always a bit confusing, we have sooooo many nodes. I think you picked a wrong one. Okay, one thing in vvvv, we start counting from 0, in abelton from 1, so lower you MIDI channel.

Hope this patch works for you.

MIDIinput.v4p (7.8 kB)

Unfortunately it doesn’t. I tried the ‘MidiController’ - Node as well. And also all 16 channels, from 0 to 15.

This ‘MidiNote’ - Node works fine for my other input device, the Korg Nano Key. (See attached the patch I found in this forum.)

And there was also another patch for to test MidiIN and OUT with vvvv. For my piano MidiOUT works, MidiIN doensn’t.

Any other ideas???

/* Posting the image (31 kB) was a question of usability and comprehension. The screenshot supports the understanding for my problem and makes the reading easier.
But I get your point. I won’t post any screenshots instead of patches again. */

Anyway, thanks for your quick support.

my piano midiIN (17.9 kB)
test midiIN_OUT (24.4 kB)
midiIN from Korg Nano Key device (28.4 kB)

hi xvii, sorry but what is exactly your device sending as signal ? I mean what are you reading as input signal other software ( ableton / midi Ox , etc)

does this piano has a 3 modes usb mode ( Input / Output / Thruth ) ?

hi karistouf,
I connect this simple midi interface http://www.m-audio.com/products/en_us/Uno.html to the midi IN and OUT of my digital piano, which works fine within Ableton. Does that answer your questions? there are no usb modes at my piano.

… but your assumption might be right, that not my vvvv-patch is the problem. Maybe this simple interface cannot handle IN and OUT simultanously? I wouldn’t need OUT anyway. But even if I unplug the OUT - cable, IN doesn’t work.

have you tried all channels on the MidiNote node?

Yes.
And I just installed two different midi monitors and got the same informations: my pc gets all the midi input signals at channel 13 (12 in vvvv). The computer gets them, vvvv doesn’t.
Don’t know what else to try.

oh wait, my first patch gets them now. don’t know why, it just does. at channel 12.
Thank you all for your interest and willingness to help!!!

so this is my final patch for getting midi IN data of an 88 keys piano, just in case, anybody else needs it.

(I don’t know, why the deepest tone is at 21 and not 0. This solution works for my piano. I get all black and white keys separately and in the right order.)

I used this tool for monitoring the midiIN signals: http://www.midiox.com/

midiIN_piano_88keys (23.4 kB)

Glad to read it works.

If I remember correct, you might get some trouble when using 2 tools at the same time begging to use the MIDI input (Like vvvv and MidiOX).

I am not getting this MIDI stuff, I used the patch I attached for my Korg Nano Kontrol, and it uses a different node.

Yes, I experienced that too. Sometimes just one application receives the midi signals. But in my case, now, both Ableton and vvvv get them.
And that’s how I could capture my vvvv-Video and simultaneously record those midi signals with Ableton for the later audio production.

You might wanna have a look, what I used this patch for.

http://vimeo.com/20016596

I still have to work on this patch, at least a bit. Sometimes, the rays cover each other, or are too thin, or their max scale value is too small.