Forum

Microsoft Kinect nodes still missing with kinect sdk 1.6 & addons installed (?)

Hi, I was not able to find the answer in the forums, so I’m writing a new thread.

I have vvvv_45beta29_x64.zip & addons_45beta29_x64.zip installed (properly in c:\vvvv - YES - addonpack folder is in the vvvv root directory (alongside girlpower), I did run crack.exe and all boxes are green and vvvv itself is running and I’m able to create new nodes), I also have fresh install of 1.6 SDK + DevToolkit and I also tried to restart Win7 Ultimate 64bit (legal). :)

I’ve also checked, if Kinect itself is working (using samples, both c# and c++ are working fine) and Kinect is connected properly.

And I’m a bit desperate as I’m not able to diagnose, why those nodes are not showing when I add new node and type “Kinect” or “Microsoft”. Addonpack is installed, as there are two other Kinect nodes (“Perspective (Transform Kinect)” and “ProjectiveToRealWorld (3d Kinect)”) which were not present (if i remember correctly) before installing addonpack.

Did some of you experienced similar situation? I’m possibly doing some stupid detail wrong, if so, please, let me know.

Thank you a lot!
m.

MS KINECT NOT AVAILABLE IN 64-BIT VVVV.

I’ve just found the answer in vvvv_64bit info section… it seems like VVVV.Nodes.MSKinect is not yet 64bit (if ever).

Is it mentioned in some Kinect section and I just plainly missed it?

Still, consider this thread answered.

in this release also the 32bit version of those kinect nodes are buggy. just skeleton and egb worked for me. anyone else?

i’ve tried the Face (kinect) node that missed some assemblies:

“Could not load file or assembly ‘Microsoft.Kinect.Toolkit.FaceTracking, Version=1.6.0.0, Culture=neutral, PublicKeyToken=null’ or one of its dependencies. The system cannot find the file specified.”

other MS kinect nodes are working fine i have kinect SDK 1.6

Quote sapo
Same problem here with:
-face
-depth
-rgbdepth

I’ve asked about this in the forum couple weeks ago. No one answered, is the Kinect implementation buggy in the new version of vvvv in general? unless you know exactly which version of what driver to use. I wish we could have a fix for this, as I’d like to reliably use Kinect with vvvv in my research at Cambridge Univ… but the 64bit version completely not working.

My question is: so simply what version and how we can currently use Kinect reliably well in vvvv? 32bit?

Noticed those issues, for some reason had those mostly with face tracker.

Sadly have issue with .net framework on laptop, so hard to do any proper testing, so will have to wait next week till i reach my desktop again.

About 64 bits, should mostly be only a recompile, so should arrive very soon.

i went back to 28.1 which still works

kinect output seems to screw it. someone told me it might have to do with the (new) 16bit

Same problem here, with 28.1 32b.

I use to have the open ni installed, i just added the microsoft sdk and:

Kinect seems to work fine, skeleton works fine, but the same 3 nodes mentioned by Noir are not working… and the Depht, only works half of the screen, ( rigth one, lesft one its black ). But skeleton traking works fine.

As an aditional question, im tring to make a clean install of my new pc, win 64b, vvvv 28,1 , which files do i need to install for the kinect ( microsoft drivers ), just the microsoft SDK or something else ? im not able to get it working on this 2nd pc

Ok so for some of the list:

  • Perspective and ProjectiveToRealWorld are not part of MS Kinect build, think they from openNI one.
  • Face still doesn’t work, have to investigate further
  • Depth is fixed. Please note that now it’s sending proper depth as L16 so if you bind as a quad it will appear much darker (as previous was cropping some parts)
  • I’ve put Alpha to 1 in player node (so no need to change pins to see it working)
  • RGB Depth should work , it’s a uv lookup table so if it looks random on display it’s totally normal :)

Attached is updated plugin

VVVV.Nodes_.MSKinect.dll_.zip (14.4 kB)