"Microsoft Build Tools 2019 not installed" when exporting

It worked on the other preview earlier
Everything seems to be installed

2022.5-297 preview

It seems the error message is wrong (thanks for that) and it should say “Build Tools 2022” not installed. Can it be that this is the case for you? When you installed 2022.5 did you have the checkbox enabled on the build tools install step?


I think I have everything installed, I also updated recently because of the same error on the preview before.

Ok thanks, we’ll try to replicate on our end.

1 Like

Simply installing the same set of Build Tools as in your screenshot didn’t do the trick :(

Please do the following:

  1. Download and extract DebugView - Windows Sysinternals | Microsoft Learn
  2. Start dbgview64.exe
  3. Start vvvv.exe - you should see some Loading … messages in the debug view
  4. Open your document and press F10

You should see some sort of exception in the debug view which would be nice if you could post that here.

I have done all of the above… I don’t know what happened, but the exporting started. Again, this is the second time something like this has happened to me. Last time I updated the tools and then the error went away. I guess it’s because I reloaded the application

But there was another problem
For some reason I can’t attach a screenshot right now
But the export didn’t go through. there was an error

Something tells me it’s because of the “channels”

export_error.zip (2.3 KB)

Hm ok if it comes up again, the steps above should help us figuring out what’s going on there.

To your last error - the last line of the log says it quite clearly, no?

CSC : error CS7064: Error opening icon file D:\Projects\_juicy_gcode_wrapper\C:\Program Files\vvvv\vvvv_gamma_2022.5.0-0297-g4861c72992\Resources\icons\vvvv_MAINICON.ico -- The filename, directory name, or volume label syntax is incorrect. : 'D:\Projects\_juicy_gcode_wrapper\C:\Program Files\vvvv\vvvv_gamma_2022.5.0-0297-g4861c72992\Resources\icons\vvvv_MAINICON.ico' [C:\Users\USER\Documents\vvvv\gamma-preview\Exports\src\juicy_gcode_wrapper\juicy_gcode_wrapper.csproj]

Somehow the path to the app icon file is completely off, try resetting it in the export dialog.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.