Mesheditor and pointeditor problem (bug ?)

Hi vvvvolks.

I’m playing with the pointeditor and other mesheditor but I have the same problem with all those nodes. Can’t have something decent.

Let me show you a picture :

It happened the same with both mesh and point editor.

And… If I can open a xFile or something to edit, only the point moves but not the geometry. Seems very buggy I don’t know what to do.

Thanks for your help.

try select all the points with hotkey then deselect and then operate

Thanks antokhio,

but before that it’s very buggy with xFile, even with collada. If I load a mesh (collada or xFile, even the basic Box) it show nothing.

I tried reset button as well, looks very buggy I don’t understand and I can’t find similar problem in the forum.

that modules won’t work with collada on it’s own, it have to be modified to “eat” transforms. And only binary xfile will work 100%.
as for your question: the bug is between mesh (Split) and VertexBuffer, if vertexBuffer show’s (nil) on output try to kill connection between them and connect them again

Ok I tried your trick I found out a part of the problem. But still nothing with xFile… I just made a simple object and export it from Blender.

If I connect this xFile to a phong shader then to a renderer, it’s display correctly, but if I try to use the mesheditor module on the xfile, nothing happened…

I found the problem, the actual xFile exporter doesn’t seems to export binary xFile. I tried with an other software and it works.

Thank you for your help.