Max won't receive UDP (localhost)

Hey Vriends,

I got a problem here which seems to be very trivial, but I just can’t figure it out. Have to send values from VVVV to maxmsp via UDP, just locally.
It might have something to do with my confusion over the new raw datatype, but: When running a third party udp watch tool, the max udp sender (which is communicating fine with the receiver) seems to send a hex string, while VVVV looks like it’s sending ascii. All fiddling around didn’t help.

I attached the simple VVVV sender patch, as well as the max sender and receiver (they talk just fine with each other). The max patches can be opened with the max msp runtime:

Would be great if somebody could help, I wrapped my head around it for a couple of hours - unsuccessful.


udpSender.v4p (5.2 kB) (1.8 kB)

hei phl,

seems the max udpsend/receive nodes internally use some fancy protocoll, not plain udp. the reference mentions something of “udp fullpacket” which i find no reference of.

so three options:

  • find out how that protocoll works
  • find max-nodes that do plain udp
  • use proper osc

probably somethings here: maxmsp

Thanks for the quick reply joreg!

Will try to go for OSC then. Although the example patches on the reference site don’t work out of the box when sending from VVVV and receiving in MAX. The other way does though. I’ll have my max guy look at it.

osc worked just fine. cheers