MainLoop, vvvv time tweaks for nrt

is there a way to tweak timing some how so vvvv pushes correct steps on all time based values?
i have scene i want to render, but if i got FPS set to 5 i got integrate witch counts instead of 1/25 1/5 so everything becomes 5 times faster. any intelegent way to deal with that? or i need to route multiplier to all time based params myself?

i’m not exactly sure what is the problem… if you change fps from 25 to 5 it seems correct that everything goes 5 times faster (then when you write an image sequence, and play it back at 5 fps, animations should appear to have the correct speed)

are you using Increment Time Mode ?



if it is still relevant,

i am doing frame-based time modules for that, using FrameCounter,
for example to simulate an 1 second period LFO (assuming you need 25 fps)
i take a frame counter, reset it each 25 frames
and dividing its output by 25 i get linear ramp from 0 to 1
exactly during 25 frames not depending of current FPS.

maybe its a stupid way but it works for me

hope it helps

Try using increment mode in mainloop, it does all that for you. If I understand you right.

good`ol + and framedelay should help. If I understand any of this right.

you never actually know with which framerate your scene will be rendered,
it can vary depending on complexity of the scene.

for sure incremental mode helps you to avoid dropped frames,
but time nodes depend only on system time,
and so their speed relative to frame based time will also vary.

that is why i am using framecounter for animations,
and also timeliner driven to next frame by framecounter

  • and framedelay is also fine i guess!
    thanks stix

check unc’s example
it’s totally works like charm

have you ever know em not to?

well i knew about that Increcement option before, but it was not obvious how it’s works, untill i’ve seen that example.

@ain, if you set the mainloop to increment the time source of all of vvvv’s animation nodes is the frame, not the system time. so an LFO set to 1 second with manloop incement time mode set to 25FPS is doing exactly the same as your framecounter based LFO. that’s the reason why this mode exists…

thank you guys for clearing it up and sorry for being so silly ~

i just was setting mainloop to 2 fps in increment mode to test,
and lfo was doing two steps 0 and 0,5 )) (and framecounter lfo wasnt)
so didnt realize that with 30fps increment evrth would be fine
that when it is slow because of rendering it is different