Forum

Low framerate

i have a dualscreen setup, running different resolutions on each display. when i set both renderer to fullscreen (at the native desktop resolution) the framerate drops dramatically.

one observation, if just one renderer is set to fullscreen and the other one is windowed but resized to fill the whole screen, then everything is fine…full framerate.

its just the state of both displays set to fullscreen.

nvidia graphics card setting is set to multidisplay mode.

has anyone came across a similar behaviour ?

yes, fullscreen on two independent heads is not usable, but no idea why… does it help to change the presentation settings of the renderer in the inspector?

aha, good to know.

strange, my vj set at node08 was running on two heads in fullscreen and i can’t remember having any problems.

anyway, i will test the presentation interval setting or just set one renderer to windowed. is there a way to set the borderless mode (ctrl+8) automatically without using the keyboard node?

cheers

OMG I have this on a project next week! Since when has this happened? Do I have to roll back some versions…??
balls

is this a new behaviour ? the special thing about my problem patch is different resolutions on both heads. not sure this is the cause.

but running the same resolution on both heads definetely works as i have countless projects which run fine…in fullscreen on both heads.

Ah, I thought it was just 2 fullscreen outputs, phew!

sorry for dramatize this issue, i just remember that i had to run the second output of my last project in windowed mode, because of this. i haven’t tried two heads with the same resolution…

and do you know a trick for the ctrl+8 borderless behaviour ?

i tried with keyboard and the KillBoarders module, but worked not really good, so i left the borders because it was only the gui for the moderator…

ok i see.
i checked the module and i’m amazed how quick the focus can change while sending the key command. i would never tried this.

i changed the patch and now it starts with a borderless renderer. hurra

KillBorder_test.zip (5.3 kB)

We had the same bug on a recent project and tried to find the cause with the following result:

  1. happens even in empty patches with just two fullscreen renderers and spinning quads.
  2. same bug on every beta version down to beta20
  3. tried different SlimDX versions, no change. Tried on clean systems but always windows xp service pack3
  4. happens even on ATI cards and totally different computers, but not on all computers.
  5. it happened on computers where it had worked before
  6. playing around with renderer settings doesn’t do much

I cant remember if we tried the same resolutions on both outputs…

However: crazy bug!!!

The unlikely solution was to use Windows 7. Even if it’s ugly, it worked. And as an added bonus: vvvv’s multicore behaviour improved as well.

wild guess: can anybody experiencing that problem try to set MainLoop (VVVV) 's Improve Timing Precision config-pin to true and see if that does something?

Yes I tried the Timing Precision but it didn´t make any difference.

i tried all possible messing with renderer settings and mainloop. no effect.

my patch runs now with one borderless window…all is fine.