Forum

Lots of questions

Well, I still can’t get into IRC, which is frustrating, so for now I’m just gonna ask my questions here.

First off, I’ve been using some of the freeframe trackers and such, and having a blast with them. BUT, I have to have a renderer attached to the output of, say, the fiducial tracker, and it has to be visible and enabled for it to even track anything? Why is this? And if I want to have another renderer fullscreen, to show the stuff I have reacting to the fiducials and such, it stops tracking, I’m assuming, because the output renderer is not visible.

On my laptop, I have set up Dualview with a crt I have here, and I’m trying to get a renderer fullscreen on the crt, but even just moving the renderer over to the crt totally messes up vvvv, like it doesn’t respond, or at least not very well, and I gotta quit vvvv and open it back up. I’m using the color tracker to make a neat little laser pointer tracker, using a rope node to draw the line, and I want to hook up my laptop to a projector, have the projector as a second monitor, and have the trail show up (fullscreen) on the projector.

Also, what is the best way to get video (from my mini-dv camera hooked up thru firewire) into the freeframe nodes? Initially, I used just a videoin to the node, but (especially annoying with the fiducial tracker, as it totally screwed up the tracking) it almost has an interlaced look to it, when objects are moving fast. I recently saw (can’t remember where) a method going:

VideoIn > VideoTexture > Quad (scaled*2) > EX9 Renderer > DX9Texture > AsVideo > freeframe node

It works great so far, and it gets rid of the streakiness I had with the other method, but I had seen in another post that AsVideo is slow, because it has to transfer from the gpu to the cpu. What’s the best way?

Alright, I think I’m done rambling for now. BTW, vvvv rawks!

would have been better to post each question in single thread.

On my laptop, I have set up Dualview

have a look at your Renderer in the INSPECTOR.
change the device.
IMHO it better to use the SpanMode.

VideoIn > VideoTexture > Quad (scaled*2) > EX9 Renderer > DX9Texture > AsVideo > freeframe node

that one is easy:

VideoIn > freeframe node^

would have been better to post each question in single thread.

Sorry, I’ll remember that.

have a look at your Renderer in the INSPECTOR.
change the device.
IMHO it better to use the SpanMode.

A couple things, I just tried, and setting it anything else than -1 (I tried 1 first, then 0) just stops the incoming video (again, strange) and it doesn’t do anything. I only tried dualview because I didn’t know it would work in spanmode. How do I get that to work? (not spanmode, but getting it to work in spanmode)

that one is easy:

VideoIn > freeframe node^

I dunno if you read the whole post, but I had said that VideoIn > freeframe node gives a streaked (interlaced, if you will) look to the video, and totally screws up the fiducial tracker and such.

P.S. I just noticed that in my first post I said “aliased” instead of “interlaced”… “duh” moment

OK, I’ve done some more messing around, and I figured out the Device (Manual) node, and using that in conjunction with dualview, I can get fullscreen rendering on the second display.

I’m still wondering why I have to have an open renderer on the output of the freeframe plugin for it to work…

helo alex.

  • I’m still wondering why I have to have an open renderer on the output of the freeframe plugin for it to work…

this is just by design. behind the VideoIn->FreeFrameNode->VideoTexture->Quad->Renderer graph in vvvv lies a microsoft-directshow graph. directshow graphs only can operate when they have a source (in that case VideoIn) and a sink (in that case the VideoTexture). the videotexture in turn only operates when connected to a Renderer.

that renderer needs to be visible, because vvvv thinks if the videotexture is not visible it can turn it off. anyway you should e able to disable the renderer.

i admit we could have implemented that differently but for now it is like this.

  • but even just moving the renderer over to the crt totally messes up vvvv
    strange. this was the case with versions < beta9. which graphiccard does your laptop have? check for latest drivers. if you have an nvidia card you may also try this

  • VideoIn > VideoTexture > Quad (scaled*2) > EX9 Renderer > DX9Texture > AsVideo > freeframe node

  • VideoIn > freeframe node
    those are the two ways. both have advantages and disadvantages. take which ever suits you best. AsVideo being slow was mainly with pre PCI-express graphiccards and still applies if you are dealing with large textures.

  • spanmode/dualview
    notice that in spanmode you cannot go fullscreen on one monitor and have the other monitor still showing a patch. this is only possible in dualview.