Loading .dll problem


I´m struggling now for some time with a .dll import from an external sdk.

The sdk is from ROBOTIS, a robot kit/servo manufacturer. Two years ago I set the template with the dll up on my desktop and it was working like a charm, also with Win8 installed one year later on another SSD.

Now I can´t get it working on my laptop. The steps I took chronologically:

-cloning the template(Value)
-dragging the .cs from the sdk into the vvvv window, also copying it into the folder of the node in the plugins folder
-in project explorer I imported the .dll as a reference in the appearing .csproj category after putting it in the node´s /bin/Dynamic folder

  • in the node itself I added the “using ROBOTIS”, which is not giving an error

now I get an error in the node´s script called: “es wurde versucht eine Datei mit einem falschen Format zu laden” - “it tried to load a file with a wrong data format”

does someone know why this is happening and how I can solve this issue?

thank you very much, greetings

This error usually comes up when you try to load a 32bit dll from a 64bit process or vice versa.

the sdk is saying it´s a 64 bit dll and I tried it with vvvv_45beta34.1_x64 and _x86, so I don´t think that that´s the problem. it seems something else is the problem

Hm hard to tell. Guess you’ll have to pack it up in a zip file and post it here.

thank you elias!

I solved it and again it was one of these tricky things to figure out. As far as I understood it the .cs is a wrapper for the c++ library. What I did was importing the .cs in the uppermost part of the project explorer (above references in hierarchy.)