LinearFilter not spreadable?


I noticed, that when I give LinearFilter two values and two filter-times, only the first value in the input spread will be filtered corresponding to the first filtertime in the filter-time input spread.

with kind regards and respect to your work,

Robert Schulze

both LinearFilters work fine for me with spreads. seems to be another problem. what do you want to patch ? is one filter time 0 ?


well I tried it without a specific patch around it, and it worked indeed.

Hmm, the patch I tried is at

Its a test for some kind of a dmx-studio. Start the Clock to test. Reset afterwords - it’s not finished yet :-)

the file doesn’t load … upload it as attachement ?

The webserver is obviously serving vvvv-patches a text/html :-)
Here it is as attachment…

Tabellentest.v4p (14.4 kB)

ok, i dont checked all, but the spreadcount of the Stallone is switched to one after some seconds … then you have only one slice left to the LinearFilter …


after 1 second, there are 2 sets of data, which should be filtered (rows 2,3 in the table). The Spreadcount of the stallone is 2 then. After 2 more seconds, there is only one set of data (row 4), then spreadcount is 1.

Thats correct and the planned behavior.
If you stop the clock after one second from the beginning, you can see that obviously everything is correct.


I know why…

As at second 0 there is only one slice in the spread, which can be referenced by the filter later on. At second 1 there is one slice which has a previous value, and one completly new slice which has no previous value - so this value cannot be filtered.