Legacy OSC behaving weird

When trying to install a big old patch on a second setup, it didn’t work, although it worked fine on another machine with the same version of windows and vvvv. (win7 x64 and vvvv beta33.7)

i have narrowed it down to the legacy OSC nodes not working the same way on all systems.

see attached patch, it works fine on my setup, but like in the video on the new setup.

EDIT: added the patch itself

OSCtest.v4p (9.8 kB)

just tried adding a TTY renderer, it is silent

the new raw nodes are working nicely, but it would of course be the most comfortable for me not to have to change the whole setup from string to raw.

can’t watch the video on my mobile but one thing i could think of is different system locales. is the non working system set to an Asian locale?
anyway those problems with strings in network applications is exactly the reason we introduced a native RAW datatype. so switching to raw would definitely be the way to go and should not be too muvh work.

That was it joreg.

for some reason it was set to chinese for non UTF8.

anyway will probably swap to raw nodes when time permits