Joywarrior Gamecontroller node - missing axis and buttons output pins?

hi there,

I try to use a Joywarrior Gamecontroller through its vvvv node (GameController (Devices Joywarrior)) without succes. I made the electrical connections (potmeters, buttons and USB cable)and the controller is recognized by Windows XP when I connect it to my computer. In the controller properties there are recognized, callibrated and are working all 8 buttons and 3 axis.
However in vvvv there are missing the output pins of buttons and axis and I cannot figure out how to use the node. In Inspector I can see them (look at the attached image) and they are working correctly. I tried also with other gamecontroller nodes (Analog and MSFreeStylePro) but no luck. They only see two potmeters. I have read this thread: also but not helped me. Someone please?

I don’t have the device, but it says in the documentation that the joywarriors ar HID 1.1 compatible, so you could try using it with the HID nodes to see if that will work out.

Thanks for the tip. I already tried that like in the thread I linked, but I dont know how to use it correctly... Now I observed that the link mentioned is not working, sorry. Here is the good one: [dualshock-2-sony-playstation-2-controller]( Its siliconsouls Sony PlayStation 2 Controller. But only the threee axis works in that configuration, and beeing a beginner I dont know what to do.

I modified the patch of siliconsoul, and now I have all the buttons and axis. But there are some problems. The outputs of the three axis are not stable, they are varying a little bit, almost continuously if they are not in one of their endpoint (-1 or 1). And sometimes the buttons freezes, and I have to disable and reenable the HID node to work again… I attached the result

JoyWarrior Controller.v4p (28.9 kB)

Strange… now the MSFreeStylePro GameController recognizes the buttons but the three axes are not working. Anyone used this JoyWarrior interface with succes?

No one? The JoyWarrior Controller patch I uploaded would be OK if the problem with the axes could be solved. I don`t know, maybe the potmeters? We need some special precision potentiometers to Joy warrior JW24MOD-A8 circuit? In the datasheet of circuit nothing is mentioned about this.

I attach a video to show what is happening. After I tested the 8 butttons I rotated the potmeters and a few seconds later I set them back to their initial value. You can see how the three axes output values are changing.

video (637.3 kB)

I found myself the answer finally. These flickering values can be filtered with hysteresis node…