Forum

Issues with DMX (Network Artnet Sender) and Artnet (Network Sender) nodes on multiple universes

Hi there,

I’m making a scenography with led stripes controlled by an Artnet interface.
It’s worked like a charm with three to four universes driven by the DMX(Network Artnet Sender) nodes.
When I’ve started to add more universes (more than six), the led stripes started to get buggy (latency and even not lighting at all).
I’m pretty sure the problem comes from the node (or v4), the led stripes work with the same led mapping in Resolume.
I’ve joined an image of my ArtNet sending module, I generate a big color spread, convert it to GRBW and cut it in part of 512 to feed my eight universes.

image

In trying to solve the problem, I wanted to use the ArtNet (Network Sender) node but I didn’t find how to make it work.
I’ve got this message in my tty console :
“couldn’t connect pins of nodes IOBox (Value Advanced) and ArtNet (Network Sender Internal).”
The ArtNet (Network Sender) help patch work (in local) but when I try to use it with the port 6454 it doesn’t work (even if I launch v4 with another ArtNet port by command line).

Thank you in advance for your help !

Try the new VL ones they work much better for larger pixel counts.

Hi @catweasel !

Thanks you for your quick reply, I’ve tried this solution but it doesn’t seem to work.
I’ve made this simple patch :
image

And I’ve modified my patch as this :
image

As you can see, I’ve changed the artnet port of the DMX node by command line.
Strangely, the DMX node seem to stay at the same port (6454) and send the data to the led stripes.
I’ve checked the system monitor and the 6454 port is used and not the 5685.

Unfortunately, I can’t change the port of my ArtNet interface.

Not at my pc now, but there are some artnet VL modules in the node browser, so you don’t have to roll your own, but if you change the port of the VL node that should send to that port, and you will want to get rid of the old DMX nodes as they might block the port they open anyway.

It’s the ArtNet (Network Sender) node ?

I’ve already tried this solution but I’ve got a “00:20:04 * : couldn’t connect pins of nodes IOBox (Value Advanced) and ArtNet (Network Sender Internal).” in my TTY renderer console, event if I delete the DMX nodes.

this is merely a warning and should not be an actual problem in this case.
but i can confirm that something is fishy: indeed for some reason the ArtNet () nodes exactly refuse to work with port 6454 and only work with all others… have to investigate…

Hi @joreg !

For me, ArtNet(Network Sender) work in local with another port than the 6454 (but I can’t change the port of my ArtNet interface which drives the Led stripes).

It may be a problem of concurrency between the port of the DMX and ArtNet node.
Do you have an idea of why the /artnetsendport argument doesn’t work?

I think the port is only for the legacy nodes?

Artnet.v4p (9.7 KB)
Delete your args txt, reboot to make sure the port isnt still blocked for some reason, and try this patch, I dont have any devices setup at the moment so can’t fully test…

right, i got confused myself because the ArtNet (Network Sender/Receiver) helppatches have the nodes in there twice, once where the port is set to 6454, that is why when changing the IOBox in the helppatch to 6454 it wouldn’t work because the port is occupied already.

so to confirm: no need to deal with commandline or old nodes (DMX…). just make sure new nodes (ArtNet…) are only used once!

Artlib_player.zip (549.2 KB)
Please check if it works. (No warranty, no support, found on my backyard)

@catweasel
I’ve tried your patch after reboot and it doesn’t seem to work but thanks!

@joreg
Yeah I’ve tried to remove the Artnet node before changing the port in the help patch and it worked (in local) once in two times. But when I switch to the ip of the interface the led stripes doesn’t light up.
I’ve also tried to create an Artnet node and configure it without other node created before but it’s like the 8454 port remain occupied.

@bo27
Thank you for checking your archives for me.
Your patch seem to send artnet data but its pretty laggy and stuttered.

I wanted to make all my led mapping in v4 but I think for this time I’ll send a spout image to Resolume and map from there.

I stay open to other ideas, as I’ll like to continue working with led in v4.

Thanks you all three for your advice!

You make try to turn off windows firewall just for a sake of it ;)

@enomarin if the port remains occupied it means most likely there is still a node somewhere. please try:

  • start vvvv with none of your patches loaded, ie. only an empty patch
  • place an ArtNet (Network Sender). only the node, not the helppatch!
  • connect a spread to the input
  • set the target IP
  • enable Send

if this doesn’t work one more random idea is: could it be that you accidentally placed an artnet node into the root that blocks the port? check via ALT+R…

@joreg I’ve tried it, and also the patch of @catweasel after a reboot (to make sure the port isn’t occupied). I’ve also checked the root (with the finder too).
It’s pretty strange because all work with the DMX node and the 6454 port is taken by v4 when I check in the system monitor.
When I use the ArtNet node (after a reboot of v4), the port 6454 doesn’t get occupied.
When I test the help patch, the port 6455 get occupied and all is working in local :

@antokhio This could be the firewall but now it doesn’t work :/

I’m in artistic residency now, so it’s not my priority but I will make extensive test in the future (with different machines and other ports on the same network, with other machines on the same ports…).

I’ll keep you informed of the results!

still strange. here is another thing you could try if you want: get latest vvvv gamma preview and try the same thing there. it comes with an ArtNet (Sender) node that defaults to 6454 and should just work out of the box. under the hood this is exactly the same thing that is used in beta… would be interesting to hear if that makes a difference.

@enomarin Could you please try my plugin with lower amount of universes and channels.
I guess there are 256 universes and 131072 channels at the example - with such values it must be pretty laggy and stuttered.
Unfortunately, I’n not able to check by myself.