Forum

Interface and DPI settings

hi guys!

i recently got a new laptop, and aside of the obvious power benefits from transitioning from a 4 year old machine to a brand new one, i also got more screen resolution.
now i tried vvvv on the preinstalled vista, and there is so much space (yay! i went from 1024x768@15" to 1900x1200@15.4"!!)

unfortunately, although i adjusted the dpi setting of vista to 120dpi, vvvv does not seem to reflect this. pin-hover text and various other stuff is unreadably small. i attached a screenshot for demonstration.

does vvvv honour screen dpi settings? i found some reference to a dpi bug in the 33b9.1 release notes.
will it get better when i install XP? i will do this anyway, but i fear it will not help for this.
solutions? suggestions? working like this is really not comfortable at home, god forbid in a dark and smoky club…
http://vvvv.org/tiki-browse_image.php?imageId=6327
(“normal” type is crystal clear when image is viewed at 100%)

vvvv is best viewed with 96dpi. all other settings cause troubles. hope the 96dpi work for your eyes.

problem is, the screen does not have 96 dpi (which “modern” display does, nowadays? they are all sharper), but 147dpi.
so if vvvv is locked (for whatever reason??) to a 96dpi setting the font size is 65% of the “standard size”, which is why it’s nearly unreadable…
what are the troubles caouse by other settings exactly?

vvvv is “pixel mapped” and don’t care for DPI at all. (at least not what I can see)
I run vvvv on a 1920x1200 15.4" display as well. Everything is razor sharp but small as heck.

My eyes are good but even then it’s hard to read some times.

How about a zoom function implemented. (like the ones already there but without bugs)?

whew so at least i’m not alone with my problem. do you know why vvvv is pixel-mapped? i always thought contemporary software packages normally automatically respect dpi settings. at least that’s the experience i made on ubuntu.:-( well, i hope there’s gonna be a good solution for this…?

contemporary …zzzz

ai bilderbuchi, sorry i cannot offer you a quick fix for this.

so is it mainly the fonts in pulldown menus of the enum-iobox and in the tooltip that trouble you? the patch-graphics seem to adapt their size correctly, don’t they?

yes, patchgraphics seem to adapt.
i gotta run more tests as soon as i manage to install xp in a couple days, and will report back how the behaviour is on xp and how workable it is. maybe David can already tell more?

damn, if this prob persists, i think i should have ordered the smaller-res screen, since this machine will be mainly for vvvv work :-( i hope for the best. hindsight is always perfect…
thanks so far, 4v community is an excellent team!

to wrap this up:
xp didn’t help. 96dpi is unreadably for me, i started to get headaches (not only from vvvv), so i made extensive tests, tried nearly every custom dpi setting from 120 to 145 (a reboot between each!, can post the screenshot if needed).
settled for 135 as a compromise between readability and vvvv being least unusable. i had to get used to clicking 1-2mm beside every point i aimed at in vvvv, but well.

today i got a new, smaller resolution display for my laptop (1680x1050) and run it now at 120dpi (the other “premade” option beside 96 in windows). vvvv (and other pixelmapped softs) is better readable and the only thing still f**ked up are the text bubbles appearing on hovering over a pin.

well, should have known to check beforehand, but what do they say about hindsight…

cheers,
bb

as a small update I found out that I didn’t mention that also text I enter in the inspector is invisible. Makes for good blind-typing skills when setting node descriptive names, I know, but maybe this can be fixed more easily (height-adaptive text field or whatever) for non-default dpi?

Also, can anyone comment on how Windows 7 deals with that? I see many laptops now with 15" and FullHD (1920x1080) resolution. Can’t buy them because I couldn’t use vvvv on them. Anybody have experience with that?

Yes, “going vvvvorward” thread inspired me to dig this up again… :-)

Regarding the invisible text in the inspector on Windows 7, try this if you have text at 125% or higher:
Control Panel\Appearance and Personalization\Display\100%

Edit: I see now it why it worked for me: by going to 96 dpi at 1280x800
Not much help for higher resolutions. My eyes are happy with lo-rez I discovered.