Http get & vvvv / command of Teradek Colr


#1

Hi,

I’m trying to remote from vvvv a Teradek Colr .
It’s a color grading device, accepting 3D LUT files.
It can be remoted using a web browser.
My goal is to remotely set the used LUT table.

I think I managed to record the packets sent from the browser to do this.
Here is a copy of the packet:

192.168.1.200 HTTP 561 GET /cgi-bin/system.cgi?command=lutcontrol&action=set&channel=1&mode=split&name=Grayscale&_=1497622017025 HTTP/1.1

I’m trying to replicate this packet in vvvv, but I’m failing actually.

Has anyone tracks that can help me ?

Thanks

Mehdi


#2

have you tried entering that url into the HTTPGet (Network) node? also see the nodes helppatch. if you did that already, what seemed to be the problem?


#3

Hi,
I tried this, it was not working.
I attach a screenshot of the network capture.
I have only basic knowledge of that kind of network protocols.
If someone has any tips for me, they are welcome !


Thanks !
Mehdi


#4

so what exactly was not working? since you’re not sharing a patch i can only guess that you entered the URL into the nodes URL input and then hit Refresh. how are we supposed to know what happened next if you don’t tell us.

  • did you observe the In Progress output?
  • did the On Completed output eventually bang? did
  • what did the Status, Header and Body outputs report then?
  • how does their output differ from the output you expect?

#5

Hi,
You’re right, sorry for the lack of infos.
I just realised I had to Alt-RightClick the HTTPGet node when changing the URL during my tryouts, otherwise the In Progress pin is still on, and I think the node still trys with the first URL.

And now it works !

Thanks for the help !

I will make a little patch and post it.


#6

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.