Forum

How to use the texcoords of xfile

Hi vvvvusers,

i’m experimenting with xfiles,
i made one model and the correct UV mapping in the 3d software, now i want to put the textures with it’s UV mapping inside the model in vvvv, but how to use the texcoords from vertexbuffer split? Give strange result here what’s i’m doing wrong?

see attach patch

Thanks

there’s no patch attached.

sorry, but i choose a zip file in the attach field and after i hit post no file appears… i have tried to edit and re-attach it but nothing. What’s i’m doing wrong?

BTW here the file http://www.lanvideosource.net/test_texture.zip

First thought: Enable depth buffer format to D16 in your renderer (via Inspektor).
Second thought: No idea … ;D

ok frank thanks for the depth buffer now we can see clearly the texture doesn’t use the UV coordinates from the xfile… so what’s to do in order to have the proper texture work as it was in 3d software?

If u open the jpg texture u can see the uv work that has been done, maybe it’s wrong this approch in vvvv.

concerning upload problems please report your setup in the: vorum upload problem thread

hi e1n:

the textures coordinates in your .x file is just wrong oriented…

i rotated the whole coordinates with rotate aound the x axis by -0.5 and everything fits fine… maybe you can set some texture coordinate orientation options within your .x exporter so you dont have to do it in v4.

check the patch (modified you texture with colors to make things more visible)

test-texture.zip (2.4 MB)

hi elektromeier,

thanks for the tip, i manage the right orientation also
with tralslate y to 1, or also with the texcoords, vector split and + value and 1 to all Y and then in vector joint again …
I don’t know what’s the lighter tecniques.

I use blender to export x files but i can’t find the right option in the exporting menu…Someone know how to change UV orientation in blender?

BTW the main problem now is the fine black line around all pieces of textures…how can i eliminate it?
I have try with same little scaling but without success.

see the attach patch
http://www.art3ch.net/test-texture.zip

Hi all,

I manage to register this video,
http://www.vimeo.com/2050767

but the problems with fine black line remain in the render as u could see in the video,

could someone have a look to the patch (see above post) and help to understand the problem behind this black line around all pieces of the textures?

Thanks

hi e1n,

i think the black lines appear because the uv-mapping of the model is not fitting the texture precisely; you’ll have to adjust those.

also, i don’t think you have to split and join your mesh like that. you are not modifying any information, so you can just feed the mesh directly into the shader.