Forum

How to apply Homography to Stride Camera?

hey all,
seems like I’m missing something as I don’t get Homography Transformation to work:

I see my plane when I disable “Use Custom Projection Matrix”, but the Matrix coming from the Homography is killing it…? Should it even be applied to the camera…?
Thanks in advance!
clockdiv

Just a guess there is renderer window, maybe it would work with that?

cool. that’s a solution!

still, shouldn’t it work as the Projection Matrix for the Camera as well 🤔? Seems like an unnecessary texture / amount of memory out there…

Well, just a guess, again but projection matrix for 3d works a bit different then 2d one, as an option you can try to override zfar znear, maybe this is problem…