GPU Particles - wrong clipping, z buffer problem?

Hey vvvveople,

as you can see in the confusing picture the boxes dont get rendered in the rigth order.
Have a look in the patch. it uses the mesh and shader from the static_allocator example patch from dottores lib.

i allready lined out everything i know and reduced the problem as much as possible.

is this a z buffer problem like it is diskused in this thread?

or has it something to do with the texturecoordinates?

or could it be that somehow a wrong transformation is applied?

i checked everything but found nothing… and realy need help with this!

edit: file should work now

particles cliping.rar (11.7 kB)

okey i implemented the hlsl code from ParticlesGPU_Odd-EvenMergeZsort 1.0 in the other shader now and added this z sort module.

it realy gets ugly now.

basicaly the sorting works. but everything is very jumpy in relation to the changing camera position.

do you think there is a way to render particle geometry with sorting and without having the particles jump around all the time?

particles clipping 3.rar (18.2 kB)

hey tekcor, just enable the depth buffer in your first sample to fix this. (the one in the final renderer) Unfortunately it is a rather silly default in vvvv to have it set to “none” imho.


3 days and half of my weekend and its just one click.

thank you so much m4d :D

i feel your pain. been there before… ;)