Forum

Geometry mixup + texture fx chain


#1

hey there,

after years of sniffing into VVVV finally I am building up my vvvvery first patch. Now I got stuck or maybe it’s bugz…?!

I got 2 meshes (geometry1 and geometry2). Each go to a PhongDirectional and then are interconnected with the group node, which is connected to Renderer(ex9).
That renderer is just for preview purpose, built into the patch GUI. Another connection goes from group to another group (to connect with other stuff) and give me a final output… but: the second renderer (DirectX Renderer Window) doesnt show the geometries like the first one.
Question: In the first renderer geometry 1 is inside of geometry 2, in the second renderer geometry 2 is below geometry 1?! Why doesnt that work??

  1. got a texture fx chain after the second renderer which goes to a third renderer (Preview, should be spout output) but whenever I enable an effect in the chain, the renderer goes black. Happens with Glow (EX9 Texture Filter), Growth, Edge etc… Only Invert is working! And very strange: with invert enabled all the other fx are working aswell.
    So what can I do here, I mean it looks cool, but… sehr seltsam :D

Currently using 45beta34.1, before 45beta33.7

thx!

strange_behavior.v4p (49.9 kB)


#2

Your first problem will be fixed by turning on a depthbuffer on the renderer (look at it with inspector)


#3

hey eea, thanks a lot, first works now!

second I can temporarily fix by opening D9Texture Node in Inspector and clicking on repair for several times… but the 3rd renderer will stay black on next startup. doesnt feel like a solution (also tried different texture formats and other stuff)


#4

changed vvvv installation to x64 and the texture effects do work now