Fullscreen Format

For some reason I am not able to set a higher bit depth than X8R8G8B8 for fullscreen mode, though it’s up to 10 bit when windowed. Is that due to poor gfx hardware or is there any other trick?

there is a 10bit fullscreen format: A2R10G10B10 which should be available in the dropdown list on devices that support it. which graphiccard are you using? do you have a 10bit display?

It’s only available for windowed mode. Tested on both a GeForce 8800 GTS and a QuadroFX 1600M (which is basically the CAD Version of a 8700, AFAIK).
But I found a weird work-around: One has to output the renderer as DX9Texture set to a higher bit depth and feed it into a second renderer which will then display the content in full 16, 10 or whatever bit…

aha, i know that the ati FireGL V7200 offers the A2R10G10B10 in the fullscreen format options.

doubting at your weired workaround…what device are you testing with to know that you are actually seeing 10/16 bits per pixel?

So it might be nVidia related I suppose.
I had some nasty quantizing issues (mainly banding) that was pretty obvious (and clearly traceable) in 8-bit-mode - but now everything is smooth which leaves no doubt to me, that it’s calculated with higher precision.

ok, that is something different. so you still see only 8bit per pixel, but the calculation is done at 16bit of course if you use such textures.

Yes. But how come I am allowed to choose from higher bit depths in windowed mode then? I don’t get the point what determins the precision in the end. The image becomes smooth when I switch the windowed renderer to 10 bit as it’s calculated in 10 bit and output in 8 then. But there’s no way to apply this method to fullscreen which I think is weird.
Instead attaching a DX9Texture node with higher depth seems to switch the internal calculations - without even touching the renderer’s settings. But still I have to feed it into a second pass to get the final image in fullscreen.

I made a simple example to show you what I mean.

depth test.zip (161.2 kB)

right, i understand your confusion but you observe it just like it is. it seems that only the newer ati-cards allow for the 10bit fullscreen-mode. windowed and fullscreen-modes are obviously different pairs of shoes.

note though, that this is not a vvvv, but a directx/driver thing.