Flash bug

as far as i know is flash rendered via activeX plugin in explorer as well as vvvv…right ? but i came accross a difference twice.

a year ago i had a flash project which ignored the actionscript in the first frame when played in vvvv, but in explorer everything worked fine. same in the html renderer…just the flash renderer does monkey business.

now i have a as3 project, some fading script on a button object doesnt execute for some reason although it works in explorer and everywhere else.

any idea why the flash renderer is behaving different ? or maybe someone came across similar problems and has a workaround.


hello devs,

here is a flash example saved as as3 which shows the strange behaviour.

played in a flash player the swf plays til the end and stops. the same swf played in vvvv doesn’t play or when the window is resized it plays somehow, either in loop and just stops somewhere. vvvv is doing something strange with as3.

any idea ?

ups…where is the file ? next try…

wtf…now as a zip

ok…now as an external link


played in vvvv i only see black background + some colored dots. dropped into firefox i see a map. is that the problem i am supposed to see?

rightclick in the flashrenderer reports version 6, while firefox-rightclick reports version 9. same for you?

btw. what was exactly the problem with the upload? won’t it take .swf or what?

i took the liberty of narrowing down the problem.

with the attached files you can test yourself once you updated your flash activex control.

the white box is an animation on the root of the flash movie, the orange box is an object with its own timeline. the white box’ animation runs once and stopps, the orange box’ loops infinitely.

so only the white box should be controllable by the play-pin.

this works ass expected with the as2 movie, but not with the as3 one.

as you might know, the flash plugin is internally separated into the VM1 (for as1 and as2 movies) and the VM3 (for as3 movies). they have nothing to do with each other, communication between them is like communication between different flash movies in different browsers.
the tests show: the VM1 behaves as expected, however the VM3 is doing funky stuff.

whats really weird though is, that VM3 is behaving correctly, once it gets a little bit of extra focus. this focus is granted by vvvv once the context menu of the flash renderer is opened.
also it is granted, when ANY vvvv-window is getting resized. and also, when the scrollbar of the inspector is being used.

i tested it with the as3 application i am currently developing and to my surprise it worked like a charm. the problems have nothing to do with as3 code! it’s to do with using any timeline and setting the internal playhead to play().
if you use Tweener or any other tweening engine, that can play movieclips by using enterframe-event you could work around the issue.

flash_renderer_tests.zip (12.4 kB)

yo velcrome,

we found out the same thing regarding die difference of scripts and tweens and the funky focus effect.

my flash programmer works on the enterframe event right now while i was reading your post… :)

ok…i see the problem now.
i had a quick look. it is nothing obvious though…seems to be quite tricky…
how good are the workarounds?

using actionscript for animation works.

for everyone:
to be honest, i’d use flash8 and as2 if used within vvvv for now until flash9 is being integrated in vvvv.

its not fun using some local connection hack to get data into flash9 and script every animation.

oh and lets not forget the great global security setting of flash9. (what has adobe done ?)