Forum

Finder (VVVV) red node

devvvv

#1

Using b34.1_x86 and w7_x64 try

  • open Finder
  • close it
  • Ctrl F again
  • open root -> Finder node is red
  • a restart is needed to have it working again

#2

cannot reproduce with your instructions. any more details?


#3

Before posting I restarted the pc - and it has never shut down since; I uninstalled and reinstalled vvvv, plus tty was reporting nothing, and issue has been checked, before and after restart, against b33.7_x86 and b34_x86, which were both working.
Now it works, and I don’t know what happened.
True though I didn’t enabled exceptions, nor had a look at event viewer (which reports nothing “strange” anyway); my bad.
In case this pops up again, I’ll try to give more info.


#4

So this is how I managed to reproduce the issue:

  • open Finder
  • search for non existing node, even in a blank patch
  • close finder
  • Ctrl F again
  • open root -> Finder node is red
  • a restart of the PC is needed to have it working again

Here’s tty

0:00:18 ERR : Exception occurred during creation of plugin: The composition produced a single composition error. The root cause is provided below. Review the CompositionException.Errors property for more detailed information.

1) Impossibile utilizzare oggetti COM separati dai relativi RCW sottostanti.

Resulting in: An exception occurred while trying to create an instance of type 'VVVV.Nodes.Finder.FinderPluginNode'.

Resulting in: Cannot activate part 'VVVV.Nodes.Finder.FinderPluginNode'.
Element: VVVV.Nodes.Finder.FinderPluginNode -->  VVVV.Nodes.Finder.FinderPluginNode -->  TypeCatalog (Types='VVVV.Nodes.Finder.FinderPluginNode').

Resulting in: Cannot get export 'VVVV.Nodes.Finder.FinderPluginNode (ContractName="VVVV.PluginInterfaces.V1.IPluginBase")' from part 'VVVV.Nodes.Finder.FinderPluginNode'.
Element: VVVV.Nodes.Finder.FinderPluginNode (ContractName="VVVV.PluginInterfaces.V1.IPluginBase") -->  VVVV.Nodes.Finder.FinderPluginNode -->  TypeCatalog (Types='VVVV.Nodes.Finder.FinderPluginNode').

Resulting in: Cannot set import 'VVVV.Hosting.IO.PluginContainer.PluginBase (ContractName="VVVV.PluginInterfaces.V1.IPluginBase")' on part 'VVVV.Hosting.IO.PluginContainer'.
Element: VVVV.Hosting.IO.PluginContainer.PluginBase (ContractName="VVVV.PluginInterfaces.V1.IPluginBase") -->  VVVV.Hosting.IO.PluginContainer

Attached is exception log.
Also where do I find “CompositionException.Errors property for more detailed information”? So to post it here.

vvvv.exe-exception-2015-09-22.log_.zip (6.8 kB)


#5

hm…can still not reproduce with those instructions…


#6

Well, I really don’t know what to say.
Or better: do vvvv relies on specific windows services? I have touched nothing, but who knows, maybe something is screwed.
Also, maybe the same day, maybe the day before issue popped up, I installed python 2.7.10.
I have nothing more to say, than it happened again before writing this reply.
Thank you.