Forum

FileStream VLC not functioning

Hey!
I’m rather new to VVVV, let’s just get that out of the way.

I’m looking to use this software to create a projection mapping for an internship I’m currently going through. I’ve got the impression that FileStream VLC is the node to use when importing video files to loop, but the node appears red and doesn’t output anything to my renderer.
I have added the \addonpack to my VVVV, but this hasn’t solved the problem.

Have any of you guys experienced this problem?

A “trick” is to put the cursor on the node, it should show %vvvv%\addonpack\lib\nodes\plugins\FileStreamVLC.dll

Did you download the matching vvvv and addonpack versions?
Is the addonpack of the same architecture as vvvv?
Did you unzip it with 7-zip?
Is folder structure like this: %vvvv%\addonpack\lib\nodes\plugins\FileStreamVLC.dll?

have you installed VLC from http://www.videolan.org/vlc/index.html ?

look on dx11 pack pls directx11-nodes-alpha
make sure u got VC redist 2012 installed along with all others

Thanks for the replies, guys!

I’ve taken a picture of when I hover above the node - It looks correct, doesn’t it?

I have the corresponding versions of the beta and addons, and their both of the same architecture. I also have VC redist on my computer, so all of that checks out.

I tried removing everything VVVV from my computer and reinstalling it. But that didn’t work either.

This is really an annoying problem! Hah.

slightly related - using b33.7 x64 and latest dx11 build from github, node is not red but whenever I try to open a video I get the error message (in a message box) ‘The command line options could not be parsed. Make sure they are valid’

it’s because u have to copy dlls from the vlc in the vlc folder by hand
thay aren’t included in the build on git