Forum

Filestream stopped working!?

So I am using Filestream to read midi files and for some reason it has stopped working.

Filestream doesn’t even seem to load the file, as the size and duration pin both show 0.

Filestream 2 shows the correct file size and duration but doesn’t play (the position counter stays at 0).

It worked until very recently and I haven’t installed/tweaked anything.

Does anyone know of a way to fix/check this? Could it be that direct show has somehow been affected?

On a sidenote: Has anyone found a way of getting the midi notes from a midifile without having to reroute using LoopBe? It seems strange to have to do this rerouting and LoopBe can’t handle files with lots of notes as it thinks there is a feedback loop (sending and receiving in the same application, which is exactly what we have to do to make it work).

Thanks.

filestream_midi.zip - this doesn’t work here… :( (2.6 kB)

Oh forgot to mention I am running 31.2 x64.

Also just checked crack.exe and the directshow filter is deselcted and deselects itsself if I click it. Strange…

Oh forgot to mention I am running 31.2 x64.

Also just checked crack.exe and the directshow filter is deselcted and deselects itsself if I click it. Strange…

x64 should be it then. as the missing in 64bit builds page mentions some DShow9 stuff is not working. please try with x86 and report back.

Thanks @joreg.

The weird thing is that this was working absolutely fine for months till just now. I never actually use the x86 version. I just tried it in the x86 version and there as well it is NOT working. Again it shows the size and duration correctly, but does not play (the position counter is staying at 0). In crack.exe for the x86 version, directShow is ticked.

So basically I am wondering if someone else has experienced this. It just stopped working from one day to the next.

Weird.

I should mention that in both x86 and x64, Filestream does not show size and duration and doesn’t play. Filestream2 shows size and duration but also doesn’t play.

works for me with FileStream (DShow9) if it has a MidiOut (DShow9) connected (which it does not have in your example).

thanks again @joreg.

(slaps forehead) Right, I didn’t realize it ONLY works if something is connected to the DirectShow outputs. It almost makes sense, but still a bit odd, as it is not mentioned in the help file.

Also clicking through the help patch of filestream noticed that “midi playback” patch. I never realized you could play midi with Timeliner, which would be amazing for what I am doing, but doesn’t seem to work very well at all. Constant Exception errors, crashes, bpm doesn’t work, etc. It looks promising though, but probably not a priority for anyone.

So I guess its back to using it with LoopBe, which always seems like an unneccessary hack. Does anybody know of an alternative, which is a bit more performant? Midi files with lots of notes will put LoopBe in Mute mode and I am still hoping there is a way of getting midi notes from a file in vvvv without re-routing. Is it possible to control a small midi player from within vvvv? It would work with Ableton and OSC, but that seems like overkill.

i quickly tried your .mid file with timeliner and it also returned me an error which sounded like the file didn’t follow some specifications for bpm. or the implementation needs to be updated…

as mentioned somewhere earlier that would really be a rather straightforward coding exercise. based on the c# midi toolkit someone could easily write a plugin that does exactly that and again i am sure someone has already done this and only needs to step forward…