Forum

Filestream (Ex9.Texture VLC) + webcam freezing / crashing vvvv

Hello,

when using new VLC (but this also happens with “old” VLC plugin) texture to play a webcam stream (and not necessarily using pipet too) vvvv crashes or freezes. Sometimes the stream is reproduced, some other times not: both cases lead, soon or late, to the issue.
I’m not able to reproduce any step leading to this, as it happens (at least for me) randomly.
I’ve run vvvv with /showexceptions, but it simply shuts down or freezes giving no alert.

VLC 2.0.4
beta29 (obviously)
XP 32bit - Sometimes I think I should end my experience with glorious XP.

Dunno if it’s a bug or whatever, so, anyone experienced this, or solved it?

Ah, yes, see attached patch.

Thank you.

vlc+webcam+pipet.v4p (3.7 kB)

Hello,

to be more clear I have to say that:

  • in beta29 I never get images from webcam, and vvvv does not freeze or crash
    Here is what tty says:

    00:00:27 :
    ++++++++ creating renderer pair 0 ++++++++
    00:00:27 :
    [MemoryToTextureRenderer A0+](MemoryToTextureRenderer A0+) Texture needs to be resized to 2x2
    [MemoryToTextureRenderer B0-](MemoryToTextureRenderer B0-) Texture needs to be resized to 2x2
    [MediaRenderer A0+](MediaRenderer A0+) STOP Mediaplayer (Nothing Special)
    [MediaRenderer A0+](MediaRenderer A0+) Mediaplayer not stopped yet (NOTHING SPECIAL), so we will wait a little bit before we try to load a new file
    00:00:27 :
    [MediaRenderer A0+](MediaRenderer A0+) Trying to load VIDEO ‘C:\video.avi | deinterlace=1 | video-filter=gradient{type=1}’
    [MediaRenderer A0+](MediaRenderer A0+) Error opening file: C:\video.avi | deinterlace=1 | video-filter=gradient{type=1}
    [MemoryToTextureRenderer A0+](MemoryToTextureRenderer A0+) Entering MUTEX took 31,25 milliseconds.
    00:00:28 :
    [MediaRenderer B0-](MediaRenderer B0-) STOP Mediaplayer (Nothing Special)
    [MediaRenderer B0-](MediaRenderer B0-) Mediaplayer not stopped yet (NOTHING SPECIAL), so we will wait a little bit before we try to load a new file
    00:00:28 :
    [MediaRenderer B0-](MediaRenderer B0-) Trying to load VIDEO ‘D:\vvvv\v4\v4_b29\vvvv_45beta29_x86’
    [MediaRenderer B0-](MediaRenderer B0-) Error opening file: D:\vvvv\v4\v4_b29\vvvv_45beta29_x86
    ++++++++ creating renderer pair 0 ++++++++
    00:00:48 :
    [MemoryToTextureRenderer A0+](MemoryToTextureRenderer A0+) Texture needs to be resized to 2x2
    [MemoryToTextureRenderer B0-](MemoryToTextureRenderer B0-) Texture needs to be resized to 2x2
    00:00:48 :
    [MediaRenderer A0+](MediaRenderer A0+) STOP Mediaplayer (Nothing Special)
    [MediaRenderer A0+](MediaRenderer A0+) Mediaplayer not stopped yet (NOTHING SPECIAL), so we will wait a little bit before we try to load a new file
    [MediaRenderer A0+](MediaRenderer A0+) Trying to load VIDEO ‘C:\video.avi | deinterlace=1 | video-filter=gradient{type=1}’
    [MediaRenderer A0+](MediaRenderer A0+) Error opening file: C:\video.avi | deinterlace=1 | video-filter=gradient{type=1}
    00:00:48 :
    [MediaRenderer B0-](MediaRenderer B0-) STOP Mediaplayer (Nothing Special)
    [MediaRenderer B0-](MediaRenderer B0-) Mediaplayer not stopped yet (NOTHING SPECIAL), so we will wait a little bit before we try to load a new file
    00:00:48 :
    [MediaRenderer B0-](MediaRenderer B0-) FileName is empty, DEACTIVATING media player.
    00:01:12 - : AsDesktop: 1280 x 1024
    00:01:29 :
    CreateTexture(Slice 0, Device 127078432)
    [MemoryToTextureRenderer A0+](MemoryToTextureRenderer A0+) CreateDoubleTexture( device 127078432, 2x2 ) called
    [MemoryToTextureRenderer A0+](MemoryToTextureRenderer A0+) CreateDoubleTexture Created new DoubleTexture (2x2 pitch/4=2) for device 127078432 created… (dx9ex shared is OFF)
    [MemoryToTextureRenderer A0+](MemoryToTextureRenderer A0+) Added new DoubleTexture to device2DoubleTexture…
    [MemoryToTextureRenderer B0-](MemoryToTextureRenderer B0-) CreateDoubleTexture( device 127078432, 2x2 ) called
    [MemoryToTextureRenderer B0-](MemoryToTextureRenderer B0-) CreateDoubleTexture Created new DoubleTexture (2x2 pitch/4=2) for device 127078432 created… (dx9ex shared is OFF)
    [MemoryToTextureRenderer B0-](MemoryToTextureRenderer B0-) Added new DoubleTexture to device2DoubleTexture…
    00:01:31 :
    [MediaRenderer A0+](MediaRenderer A0+) Trying to load VIDEO ‘dshow:// | dshow-vdev= | dshow-adev= | live-caching=100 | dshow-config’
    00:01:31 :
    [MediaRenderer A0+](MediaRenderer A0+) LibVlc STATUS = libvlc_Error Trying to stop mediaPlayer…
    [MediaRenderer A0+](MediaRenderer A0+) Message has size 0 severity 0
    [MediaRenderer A0+](MediaRenderer A0+)
    Vlc Log contained 0 messages.

Instead in beta28.1 I just managed to save a log, which is below.

I saw (in beta28.1) in debugmode that VLC node is consuming less resources than videoin+videotexture combo, giving me the chance to exploit better my old machine. So, can anyone with a webcam tell me if he/she experience the same, either opening Filestream (Ex9.Texture VLC) helppatch with beta29 or the patch above (with beta28.1), please?

Thank you.

vvvv.exe-exception-2012-12-29.txt (29.4 kB)

I managed to solve this issue installing an old version of VLC, 1.1.9. This has been necessary either in XP 32bit and 7 64bit, since with 2.0.4 or 2.0.5 won’t show any stream (in vvvv, cos VLC stream is working like a charm). Didn’t tried later versions. I’ve got really too much of this.